Bug 1084621 - Missing information about HA queue replication.
Summary: Missing information about HA queue replication.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Installation_and_Configuration_Guide
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 3.1
: ---
Assignee: Jared MORGAN
QA Contact: Eric Sammons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-04 21:08 UTC by Alan Conway
Modified: 2015-08-10 01:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Alan Conway 2014-04-04 21:08:45 UTC
Description of problem:

From bug 1043035: 
==
documentation says that to be able to use standalone replication, ha module must be loaded on both nodes (http://deathstar1.usersys.redhat.com:3000/builds/18173-Messaging_Installation_and_Configuration_Guide/#Queue_Replication_and_HA). I added the line "load-module=/usr/lib64/qpid/daemon/ha.so" to the qpidd configuration file and according to pmap, ha module is loaded. But when I try to start replication, I receive the following error:

[root@lzhaldyb-hanode2 ~]# qpid-ha replicate -b 192.168.101.102 192.168.101.101 testQ
HA module is not loaded on broker at 192.168.101.102
==

The problem is that you also need to set
  ha-queue-replication=yes
on both brokers, this is not mentioned in the doc. I suspect I added it after providing the initial doc input. More recent doc which includes this setting is at:

http://qpid.apache.org/releases/qpid-0.24/cpp-broker/book/ha-queue-replication.html

Comment 1 Jared MORGAN 2014-09-18 00:43:46 UTC
(In reply to Alan Conway from comment #0)
> Description of problem:
> 
> From bug 1043035: 
> ==
> documentation says that to be able to use standalone replication, ha module
> must be loaded on both nodes
> (http://deathstar1.usersys.redhat.com:3000/builds/18173-
> Messaging_Installation_and_Configuration_Guide/#Queue_Replication_and_HA). I
> added the line "load-module=/usr/lib64/qpid/daemon/ha.so" to the qpidd
> configuration file and according to pmap, ha module is loaded. But when I
> try to start replication, I receive the following error:
> 
> [root@lzhaldyb-hanode2 ~]# qpid-ha replicate -b 192.168.101.102
> 192.168.101.101 testQ
> HA module is not loaded on broker at 192.168.101.102
> ==
> 
> The problem is that you also need to set
>   ha-queue-replication=yes
> on both brokers, this is not mentioned in the doc. I suspect I added it
> after providing the initial doc input. More recent doc which includes this
> setting is at:
> 
> http://qpid.apache.org/releases/qpid-0.24/cpp-broker/book/ha-queue-
> replication.html

Hi Alan

Thanks for the updated docs here.

The changes are live at http://docbuilder.usersys.redhat.com/18173/#Queue_Replication_and_HA and will be included in the 3.0 GA docs.

I've made minor grammatical tweaks to the original content as well, since I was in the file anyway. And I've made the commands into an Example to give a bit of visual variety in this topic.

I've change "ha" to "HA" as described in the qpid.apache docs as well.

Comment 2 Leonid Zhaldybin 2014-09-18 07:06:39 UTC
The documentation change checked, everything is in order.

Comment 8 errata-xmlrpc 2015-04-14 13:47:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.