Bug 108463 - gstreamer-plugins should be split up
gstreamer-plugins should be split up
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 14:55 EST by W. Michael Petullo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 10:21:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that separates aRts plugin into its own RPM (2.31 KB, patch)
2004-02-12 13:46 EST, W. Michael Petullo
no flags Details | Diff

  None (edit)
Description W. Michael Petullo 2003-10-29 14:55:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux ppc; U;) Gecko/20030130

Description of problem:
I don't want to appear as an irrational GNOME zealot, but it seems wrong that
gstreamer-plugins, a core component of GNOME, requires Qt.  The aRts gstreamer
plugin could easily be packaged as a separate RPM, say gstreamer-arts.  I
understand that Qt is required by redhat-artwork anyway...but it just doesn't
seem right, man.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Note that gstreamer-plugins requires arts requires qt.
    

Additional info:
Comment 1 W. Michael Petullo 2004-02-12 13:46:29 EST
Created attachment 97622 [details]
Patch that separates aRts plugin into its own RPM

This patch modifies the RPM specification for 0.7.3-2 so that it builds a
separate binary RPM for gstreamer's aRts plugin.  This removes the aRts/QT
dependency from gstreamer-plugins and adds it to gstreamer-plugins-arts.  In
general, more fine-grained packaging of gstreamer plugins may be nice for users
because of the wide range of dependencies within them (see Mandrake's scheme).
Comment 2 Colin Walters 2004-04-02 10:09:47 EST
After FC2, I would like to split up the plugins in a much more
fine-grained way, similar to how Debian does it.

Just splitting out Qt would be inconsistent.
Comment 3 Colin Walters 2004-05-19 11:56:42 EDT
Ok, I've been convinced that it isn't worth it to split the plugins up
(apparently it was done in the past and went badly).

One major argument against it is that it will break upgrades.  So I
guess we're stuck with it.
Comment 4 Rex Dieter 2005-02-28 11:20:58 EST
For the record, the rpms provided upstream from gstreamer.org are little more
fine-grained, but still doesn't split out arts/qt.
Comment 5 W. Michael Petullo 2005-12-26 20:34:16 EST
Could we use the lessons learned from the recent X11 split up to split up
gstreamer without causing upgrade problems?  The gstreamer-plugins package pulls
in a lot of dependencies that may not be really necessary.
Comment 6 Rahul Sundaram 2005-12-26 20:44:54 EST
Not sure why it needs to brea(In reply to comment #3)
> Ok, I've been convinced that it isn't worth it to split the plugins up
> (apparently it was done in the past and went badly).
> 
> One major argument against it is that it will break upgrades.  So I
> guess we're stuck with it.

Not sure why it needs to break upgrades. An upgrade can pull in all the packages
to resolve that as the last case and a fresh installation can install things in
a modular way. While Gstreamer is going to be used in KDE in a future version
installing QT is unnecessary in many instances. We should avoid that dependency
creep.

If there are other reasons not to split this up please mention them so that I
can document those rationale properly. Feel free to use the
http://fedoraproject.org/wiki for this.

Comment 7 W. Michael Petullo 2006-03-19 22:08:40 EST
Can we do this for FC6?
Comment 8 John Thacker 2006-04-29 10:30:20 EDT
Well, in FC5 the gstreamer-plugins-* packages don't include the
arts plugin and don't require arts or qt, so the main problem in the 
bug seems to be resolved.

It seems unlikely that it's going to be split up more than the
upstream gstreamer-plugins-base, -good etc., especially judging
by Colin Waters's comments above.  I'm just not sure that users
really want lots of seperate packages for each type of file
support (as opposed to larger things like: install this if you
use KDE)
Comment 9 Rahul Sundaram 2006-07-17 10:21:33 EDT
As per comments above, I am closing this request. 

Note You need to log in before you can comment on or make changes to this bug.