Bug 108466 - Kernel-smp causes kickstart to hang on Dell 2650 w/A15 BIOS
Kernel-smp causes kickstart to hang on Dell 2650 w/A15 BIOS
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 15:18 EST by Brian Baggett
Modified: 2013-08-05 21:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 18:54:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Baggett 2003-10-29 15:18:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007

Description of problem:
I have a very minimal ks.cfg that installs very few packages.  I have a farm of
about 50 Dell PowerEdge 2650's.  On the first 30 or so, the BIOS revision was
A10 and the kickstart worked flawlessly every time.  After I updated the BIOS to
A15, my kickstart would die at the point where kernel-smp is installed. 
Specifically, process ID number 279 (regardless of server being kicked, it was
always PID 279):

/bin/bash/sbin/new-kernel-pkg - - mkinitrd - - depmod - - install

Killing this PID, #279, causes the installation to resume.

Note the only difference at all in these 2650's is the BIOS.  There is something
with A15 that causes the kernel-smp kernel to not get installed.  However, I
noticed in my %post I upgrade kernel-smp to e.27 and this works fine.  I
theorized that the problem, whatever it was, did not exist in e.27.  So I went
into my kickstart tree and 'rm -f kernel*e.24*'.  I imported the e.27 kernel
updates, glibc-kernheaders, and the glibc updates.  I edited the comps file in
my base directory and replaced kernel-headers with glibc-kernheaders.  I then
regenerated my genhdlist like so:

/usr/lib/anaconda-runtime/genhdlist --withnumbers --hdlist hdlist /mnt/rhes2.1

I rekicked my boxes with A15 on them and all works now.

In effect, I make anaconda install the e.27 kernels instead of the e.24's in
update 2 and this fixes the problems.  This problem will likely be resolved if
there's ever an update 3 for RHEL AS 2.1.  Otherwise you guys might want to work
with Dell to resolve this.

Version-Release number of selected component (if applicable):
kernel-smp-e.24

How reproducible:
Always

Steps to Reproduce:
See above.
    

Additional info:
Comment 1 Jim Paradis 2005-09-07 16:47:53 EDT
Please verify that this is fixed with the most current update of RHEL2.1
Comment 2 Jim Paradis 2006-09-13 18:54:54 EDT
Due to lack of response from the reporter, I am closing this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.