Bug 1084822 - Inserted Pictures Replaced With Placeholder After Save, Close & Re-Open.
Summary: Inserted Pictures Replaced With Placeholder After Save, Close & Re-Open.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-06 21:33 UTC by RedHat-User
Modified: 2014-06-17 10:17 UTC (History)
8 users (show)

Fixed In Version: libreoffice-4.2.4.2-15.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-28 23:53:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
FreeDesktop.org 46447 None None None Never

Description RedHat-User 2014-04-06 21:33:08 UTC
Description of problem:
Pictures & graphics inserted into LibreOffice Impress presentation will disappear (i.e. be replaced with a placeholder) for no reason.  One can open a presentation, make a small change (to the text), save it and close it.  Upon the next re-opening of the presentation, one or more apparently random pictures or graphics will be replaced by a generic LibreOffice placeholder graphic.

Version-Release number of selected component (if applicable):
libreoffice-impress-4.1.5.3-7.fc19.x86_64

How reproducible:
I'm not sure.  It didn't start happening to me until my presentation got to ~20 slides.  This is a known bug, upstream, however.  (See additional info section.)

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This is a known bug, upstream.  Please see <https://bugs.freedesktop.org/show_bug.cgi?id=46447>.

Comment 1 Caolan McNamara 2014-04-09 14:33:05 UTC
You have a presentation (according to the upstream mention) that you can reproduce this with by just changing some text and resaving it. Can you attach that example here ?

Comment 2 Caolan McNamara 2014-04-11 11:50:12 UTC
poke, any chance of getting that sample document which is in that hard-to-reproduce-for-us state that its currently ok but a small mod + save will break it.

Comment 3 RedHat-User 2014-04-11 13:11:51 UTC
(In reply to Caolan McNamara from comment #1)
===
> You have a presentation (according to the upstream mention) that you can
> reproduce this with by just changing some text and resaving it. Can you
> attach that example here ?
===
     Back in March while I was working on my presentation, this problem seemed to happen all the time.  (In fact, just 15 minutes before my talk was scheduled to begin, I opened up my LibreOffice Impress file to find ~5 of the pictures gone!  By this time, however, I had become so use to the problem that I had all the images stored on my computer and was able it easily re-insert them.)
     Yet, now that I wanted to reproduce the problem, it eluded me.  I tried a number of things to cause the problem to re-occur:  editing my notes, inserting a slide, inserting pictures into the slide... none of them caused the problem to re-occur.
     Finally, after watching my entire slide deck (the F5 key) and editing a custom action on slide 11, one of my images on slide 30 was replaced by a place-holder after saving & opening it back up.  So, I can now give you the original presentation (with all the graphics intact) and a copy of it with that one image on slide 30 gone.
     However, I was wondering if there is a way I may upload this privately.  There is nothing in my presentation that is confidential -- so if need be, I can upload those files.  Still, I didn't write my presentation with the intent for it to be hosted on Bugzilla forever more, indexable by Google.  :-)

Comment 4 Caolan McNamara 2014-04-11 13:55:14 UTC
you can send it directly to me. 

So, if you start with the fresh original odp, F5, click all the way through to the end, and edit a custom action on slide 11, save and reload, does that reliably reproduce it ?

Comment 5 RedHat-User 2014-04-11 14:43:40 UTC
(In reply to Caolan McNamara from comment #4)
===
> you can send it directly to me. 
===
     Thank you.  I just sent you an e-mail.

===
> So, if you start with the fresh original odp, F5, click all the way through
> to the end, and edit a custom action on slide 11, save and reload, does that
> reliably reproduce it ?
===
     No, not reliably.  I just tried viewing my entire presentation (F5 key), stopping the view and editing that custom action on slide 11.  I saved the presentation, closed it, opened it back up and it was fine.
     I then made another edit to a custom animation on slide 37, saved, closed & re-opened:  it is still OK.
     I cannot reliably reproduce this.  I'll keep playing around and let you know if I come up with a magic incantation that will constantly cause this.  Sorry I cannot be of more help at this time.

Comment 6 Caolan McNamara 2014-04-22 19:35:43 UTC
I guess no luck on a route to reproduce ? I've been unable to get it to happen here locally.

Comment 7 RedHat-User 2014-04-24 14:41:42 UTC
(In reply to Caolan McNamara from comment #6)
===
> I guess no luck on a route to reproduce ? I've been unable to get it to
> happen here locally.
===

You are correct.  I have played with the file and have not even gotten it to replace one of the images, let alone come up with a repeatable method of causing it.

I don't plan to give any more presentations in the near future, but the next time I do, I'll keep this bug in mind and watch for its cause more carefully.

Comment 8 Caolan McNamara 2014-05-23 21:00:57 UTC
Might be some hope for this now, will make some test builds

Comment 9 Fedora Update System 2014-05-27 08:24:23 UTC
libreoffice-4.2.4.2-15.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.4.2-15.fc20

Comment 10 Fedora Update System 2014-05-27 13:37:58 UTC
libreoffice-4.1.6.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.6.2-3.fc19

Comment 11 Fedora Update System 2014-05-28 02:52:17 UTC
Package libreoffice-4.1.6.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.1.6.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6753/libreoffice-4.1.6.2-3.fc19
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2014-05-28 08:19:46 UTC
libreoffice-4.1.6.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libreoffice-4.1.6.2-4.fc19

Comment 13 Fedora Update System 2014-05-28 23:53:17 UTC
libreoffice-4.2.4.2-15.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2014-06-05 21:52:38 UTC
libreoffice-4.1.6.2-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 RedHat-User 2014-06-08 17:28:36 UTC
(In reply to Fedora Update System from comment #14)
===
> If problems still persist, please make note of it in this bug
> report.
===

Thank you, I will.  And thanks again to Caolan McNamara!

Comment 16 Rene Sedmik 2014-06-16 17:10:10 UTC
I noticed the bug for the first time in LO 4.2.4.2 but I experience the same unpredictable behavior. See also the same bug on Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=46447
I cannot come up with a minimal example since the bug is not deterministic. However, I noticed that it helps if you minimize the presentation and break the links to external files. As long as nothing is changed then, the file seems to stay intact. 
Please reopen

Comment 17 Caolan McNamara 2014-06-17 10:17:51 UTC
don't reopen this bug, file a new one if you have a similar sounding problem. I'm fairly confident that we've fixed a bunch of the missing picture problems under this id. (and state the exact rpm version in your new bug report)


Note You need to log in before you can comment on or make changes to this bug.