Bug 1084872 - [GSS] (6.2.x) ArrayIndexOutOfBoundsException during periodic recovery on EJBTransactionRecoveryService
Summary: [GSS] (6.2.x) ArrayIndexOutOfBoundsException during periodic recovery on EJBT...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.2.0,6.2.1,6.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: CR2
: EAP 6.2.3
Assignee: David M. Lloyd
QA Contact: Ondrej Chaloupka
Russell Dickenson
URL:
Whiteboard:
Depends On: 1035216
Blocks: eap62-cp03-blockers
TreeView+ depends on / blocked
 
Reported: 2014-04-07 05:49 UTC by Masafumi Miura
Modified: 2018-12-05 18:03 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An intermittent issue between the periodic recovery and EJBTransactionRecoveryService resulted in an ArrayIndexOutOfBoundsException. ---- [com.arjuna.ats.jta] (Periodic Recovery) ARJUNA016009: Caught:: java.lang.ArrayIndexOutOfBoundsException: 0 at org.jboss.as.ejb3.remote.EJBTransactionRecoveryService.getXAResources(EJBTransactionRecoveryService.java:112) .... ---- The root cause of the issue was that the creation of an 'XAResource' element was not contained within the associated logic loop and this led to the array index error. This element has now been moved so that it is within the logic loop and so the periodic recovery no longer conflicts with the EJBTransactionRecoveryService.
Clone Of: 1035216
Environment:
Last Closed: 2014-06-09 12:47:30 UTC
Type: Bug
sgilda: needinfo-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat One Jira Issue Tracker WFLY-3220 Major Resolved ARJUNA016009 ArrayIndexOutOfBoundsException during periodic recovery on EJBTransactionRecoveryService 2017-07-20 02:10:47 UTC

Description Masafumi Miura 2014-04-07 05:49:41 UTC
+++ This bug was initially created as a clone of Bug #1035216 +++

Backport WFLY-3220 / BZ#1035216 to EAP 6.2.x.

EAP 6.3.0 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1035216
EAP 6.3.0 PR: https://github.com/jbossas/jboss-eap/pull/1191
Upstream (wildfly) JIRA: https://issues.jboss.org/browse/WFLY-3220
Upstream (wildfly) PR: https://github.com/wildfly/wildfly/pull/6132

Comment 1 Masafumi Miura 2014-04-07 06:05:43 UTC
I've just sent PR https://github.com/jbossas/jboss-eap/pull/1193 to 6.2.x branch.

Comment 2 Ondrej Chaloupka 2014-05-05 12:34:46 UTC
It could be reproduced by btm script described in:
https://bugzilla.redhat.com/show_bug.cgi?id=1035216#c7

Comment 3 Ondrej Chaloupka 2014-05-06 07:49:12 UTC
Used verifier from bz1035216.
The array out of bound trouble was not spotted.

Verified with 6.2.3.CP.CR2.

Comment 4 sgilda 2014-05-22 14:56:13 UTC
Fixed typo in doc text.

Comment 5 sgilda 2014-05-22 15:00:51 UTC
Moved the doc text to one paragraph.


Note You need to log in before you can comment on or make changes to this bug.