Bug 1084970 - [vdsm] getStorageDomainInfo fails due to key 'info' missing from poolInfo for master domain
Summary: [vdsm] getStorageDomainInfo fails due to key 'info' missing from poolInfo for...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.3.3
Assignee: Yoav Kleinberger
QA Contact: Gadi Ickowicz
URL:
Whiteboard: storage
: 1088974 (view as bug list)
Depends On: 1033942
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-07 12:37 UTC by rhev-integ
Modified: 2019-04-28 09:41 UTC (History)
16 users (show)

Fixed In Version: vdsm-4.13.2-0.14.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, the getStorageDomainInfo action of the vdsClient command would fail when run under certain conditions. Now, the logic used to retrieve information on storage domains using the vdsClient command has been revised so that the action returns information correctly.
Clone Of: 1033942
Environment:
Last Closed: 2014-05-27 08:57:28 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0548 normal SHIPPED_LIVE vdsm 3.3.3 bug fix update 2014-05-27 12:56:53 UTC
oVirt gerrit 22824 None None None Never

Comment 1 Allon Mureinik 2014-04-21 15:12:07 UTC
*** Bug 1088974 has been marked as a duplicate of this bug. ***

Comment 3 Gadi Ickowicz 2014-05-07 13:45:28 UTC
verified on is36:

[root@purple-vds2 ~]# vdsClient -s 0 getStorageDomainInfo 1a091f8e-d4b7-4197-94d1-fc19e1e3c02b
        uuid = 1a091f8e-d4b7-4197-94d1-fc19e1e3c02b
        vguuid = rbYYcM-9TQJ-wAJw-Bawq-KS1V-P22k-KDOEnz
        lver = 0
        state = OK
        version = 3
        role = Master
        pool = ['5849b030-626e-47cb-ad90-3ce782d831b3']
        spm_id = 2
        type = ISCSI
        class = Data
        master_ver = 1
        name = ISCSI01

[root@purple-vds2 ~]# rpm -q vdsm
vdsm-4.13.2-0.14.el6ev.x86_64
[root@purple-vds2 ~]# rpm -q vdsm-cli
vdsm-cli-4.13.2-0.14.el6ev.noarch
[root@purple-vds2 ~]#

Comment 5 errata-xmlrpc 2014-05-27 08:57:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0548.html


Note You need to log in before you can comment on or make changes to this bug.