Bug 108563 - kbdrate gives no results and strange errors
kbdrate gives no results and strange errors
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 01:40 EST by Stan Mulder
Modified: 2014-02-02 12:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 16:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stan Mulder 2003-10-30 01:40:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031027
Firebird/0.7+

Description of problem:
Sometimes kdbrate seems to work, but no detectable change is found in adjusting
the typematic rate. Other times "Broken pipe" is the result. Other times a
series of carriage returns, about 10, scroll down the page.

Version-Release number of selected component (if applicable):
kbd=1.08-11

How reproducible:
Always

Steps to Reproduce:
1. open console
2. run 'usr/sbin/kbdrate -r 50 -d 150'
3.
    

Actual Results:  As regular user running /usr/sbin/kbdrate -r50 -d150: Cannot
open /dev/port: Permission denied

As regular user running /usr/bin/kbdrate -r50 -d150: Broken pipe

As root running /usr/sbin/kbdrate -r50 -d150:
 [blank line]
 [blank line]
 [blank line]
 [blank line]
 [blank line]
 [blank line]
 [blank line]
 [blank line]
Typematic Rate set to 30.0 cps (delay = 250 ms)
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#
[root@drums mtnhd]#




Expected Results:  Typematic Rate set to 50.0 cps (delay = 150 ms)

Additional info:

I'm using test3 Fedora plus all of Rawhide as of Oct 29.
Comment 1 Eido Inoue 2004-04-20 16:21:43 EDT
This seems to be dependent on the hw. fwiw, I was unable to reproduce
using the latest. No broken pipe error either
Comment 2 Roger 2014-02-02 12:36:16 EST
I'm currently seeing this bug here, on a recently manufactured motherboard exactly as the reporter stated.
Comment 3 Roger 2014-02-02 12:56:52 EST
When using X/Xorg:

$ xset r rate delay [rate]

$ xset r rate 200 30

It would appear I get the same effects with what this bug describes when I try to issue what the kbdrate command while within X/Xorg, while under a simple virtual terminal kbdrate works as expected.

As such, use kbdrate under virtual terminals only and "xset r rate" when within X/Xorg.

Note You need to log in before you can comment on or make changes to this bug.