Bug 1085702 - [WHQL][netkvm][macvtap][1 machine]OffloadRsc failed on win2012 and win8-64 guest
Summary: [WHQL][netkvm][macvtap][1 machine]OffloadRsc failed on win2012 and win8-64 guest
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Dmitry Fleytman
QA Contact: Virtualization Bugs
URL:
Whiteboard: Fixed_Not_Ship
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-09 07:38 UTC by Min Deng
Modified: 2015-11-24 08:40 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2015-11-24 08:40:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2513 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-11-24 13:38:38 UTC

Description Min Deng 2014-04-09 07:38:30 UTC
Description of problem:
1-machine-OffloadRsc failed on win2012 and win8-64 guest

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-53.el7.x86_64
kernel-3.10.0-113.el7.x86_64
build 76

How reproducible:
6/6
Steps to Reproduce:
1.boot up guest with the following CLI
  N_REPEAT=1
while true;
do date;
echo "test round: $N_REPEAT" ;
N_REPEAT=$(($N_REPEAT+1)) &&
/usr/libexec/qemu-kvm \
-M pc -m 6G -smp 8,cores=8 \
-cpu Nehalem,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic,hv_time \
-usb -device usb-tablet \
-drive file=win2012-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 \
-uuid 0a264813-2fb1-4fec-88c5-19dec63d1ce1  \
-rtc-td-hack -no-kvm-pit-reinjection \
-chardev socket,id=a111,path=/tmp/monitor-w8132-nic1,server,nowait -mon chardev=a111,mode=readline \
-name win2012-nic1 \
-vnc :1 -vga cirrus \
-monitor stdio \
-netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:32:14:46:20:11,id=net0 \
-device virtio-net-pci,netdev=hostnet1,mac=e6:b3:cc:b1:2b:73,id=vnic0 10<>/dev/tap10 \
-netdev tap,id=hostnet1,vhost=on,fd=10 \
-global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1
done
N_REPEAT=1
while true;
do date;
echo "test round: $N_REPEAT" ;
N_REPEAT=$(($N_REPEAT+1)) &&
/usr/libexec/qemu-kvm \
-M pc -m 6G -smp 4 \
-cpu Nehalem,+x2apic,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic,hv_time \
-usb -device usb-tablet \
-drive file=win2012-nic2.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none \
-device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 \
-uuid be330f38-938a-4449-a0c6-f43058dbe9f0  \
-rtc-td-hack -no-kvm-pit-reinjection \
-chardev socket,id=a111,path=/tmp/monitor-w8132-nic2,server,nowait -mon chardev=a111,mode=readline \
-name win2012-nic2 \
-vnc :2 -vga cirrus \
-monitor stdio \
-netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:12:54:3c:11:71,id=net0 \
-device virtio-net-pci,netdev=hostnet1,mac=52:e0:00:0b:9a:5a,id=vnic0 11<>/dev/tap11 \
-netdev tap,id=hostnet1,vhost=on,fd=11 \
-global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1
done

2.submit the jobs 
3.

Actual results:
The job failed 

Expected results:
The job could pass 

Additional info:
/4/2014 9:45:25.418 AM Enable RSC 
Error 4/4/2014 9:45:25.418 AM OID_TCP_OFFLOAD_PARAMETERS set returned with error status = 0xc00000bb 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50007 
Error Text:   The storage control blocks were destroyed. 
Error 4/4/2014 9:45:55.418 AM Timeout occured waiting 30 seconds for NDIS_STATUS_TASK_OFFLOAD_CURRENT_CONFIG to occur 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50012 
Error Text:   There are no more files. 
Error 4/4/2014 9:45:55.418 AM NDIS_STATUS_TASK_OFFLOAD_CURRENT_CONFIG indication returned with error status = 0xc0000001 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50008 
Error Text:   Not enough storage is available to process this command. 
End Test 4/4/2014 9:45:55.418 AM Enable RSC 
Result:   Fail 
Repro:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRunABD1B3B3-27FC-405C-B9FA-235797F7D1E0\ndistest.net\ndistest.exe /logo /auto /client /target:Miniport /tc:PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&0&20 /jobs:lan\OffloadRsc.cpp 
 
 Failed 
 Start Test 4/4/2014 9:45:55.418 AM Disable RSC 
Error 4/4/2014 9:45:55.418 AM OID_TCP_OFFLOAD_PARAMETERS set returned with error status = 0xc00000bb 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50009 
Error Text:   The storage control block address is invalid. 
Error 4/4/2014 9:46:25.418 AM Timeout occured waiting 30 seconds for NDIS_STATUS_TASK_OFFLOAD_CURRENT_CONFIG to occur 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50012 
Error Text:   There are no more files. 
Error 4/4/2014 9:46:25.418 AM NDIS_STATUS_TASK_OFFLOAD_CURRENT_CONFIG indication returned with error status = 0xc0000001 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50010 
Error Text:   The directory cannot be removed. 
End Test 4/4/2014 9:46:25.418 AM Disable RSC 
Result:   Fail 
Repro:   C:\WLK\JobsWorkingDir\Tasks\WTTJobRunABD1B3B3-27FC-405C-B9FA-235797F7D1E0\ndistest.net\ndistest.exe /logo /auto /client /target:Miniport /tc:PCI\VEN_1AF4&DEV_1000&SUBSYS_00011AF4&REV_00\3&13C0B0C5&0&20 /jobs:lan\OffloadRsc.cpp

Comment 5 Min Deng 2014-04-18 07:54:05 UTC
  For this bug,it should be build 76'issue because I still could reproduce the issue via build 76 but I could not reproduce it via build 79 on both win2012 and win8-64 OS.Anyway,the issue has been fixed in build 79.

Thanks
Min

Comment 7 Ludek Smid 2014-06-26 11:17:01 UTC
This request was not resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you need
to escalate this bug.

Comment 13 lijin 2015-07-17 07:56:34 UTC
change status to verified as this job is excluded in the latest build and rsc job issue can be tracked by bug950611

Comment 15 errata-xmlrpc 2015-11-24 08:40:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2513.html


Note You need to log in before you can comment on or make changes to this bug.