Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1085706

Summary: virsh numatune should forbid to accept int as parameter values
Product: Red Hat Enterprise Linux 7 Reporter: hongming <honzhang>
Component: libvirtAssignee: Martin Kletzander <mkletzan>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: low Docs Contact:
Priority: low    
Version: 7.0CC: dyuan, jmiao, mzhan, rbalakri
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libvirt-1.2.7-1.el7 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-03-05 07:33:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description hongming 2014-04-09 07:47:43 UTC
Description of problem:
virsh numatune should forbid to accept int as parameter values. Maybe modify manual and help and add description about integer parameters
 

Version-Release number of selected component (if applicable):
libvirt-1.1.1-29.el7.x86_64 

How reproducible:
100% 

Steps to Reproduce:
[root@ibm-x3850x5-05 ~]# virsh help numatune
  NAME
    numatune - Get or set numa parameters

  SYNOPSIS
    numatune <domain> [<mode>] [<nodeset>] [--config] [--live] [--current]

  DESCRIPTION
    Get or set the current numa parameters for a guest domain.
    To get the numa parameters use following command:

    virsh # numatune <domain>

  OPTIONS
    [--domain] <string>  domain name, id or uuid
    [--mode] <string>  NUMA mode, one of strict, preferred and interleave
    [--nodeset] <string>  NUMA node selections to set
    --config         affect next boot
    --live           affect running domain
    --current        affect current domain


[root@ibm-x3850x5-05 ~]# virsh numatune rhel7
numa_mode      : strict
numa_nodeset   : 0

[root@ibm-x3850x5-05 ~]# virsh numatune rhel7 0 1

[root@ibm-x3850x5-05 ~]# virsh numatune rhel7
numa_mode      : strict
numa_nodeset   : 1 

Actual results:
When pass integer as mode value , numatune can change the nodeset. 

Expected results:
virsh numatune should forbid to accept int as parameter values. Maybe modify manual and help and add description about integer parameters.

Additional info:

Comment 2 Martin Kletzander 2014-07-09 13:12:13 UTC
Fixed upstream with v1.2.6-114-gfd59f6c:

commit fd59f6c83e5f3dbb44ad93de0568f9f3158fbb4d
Author: Martin Kletzander <mkletzan>
Date:   Wed Jul 9 09:53:14 2014 +0200

    virsh: document the possibility of accepting integers for numatune mode

Comment 4 Jincheng Miao 2014-11-19 09:21:23 UTC
The verification steps are:

# virsh numatune r71
numa_mode      : strict
numa_nodeset   : 

1. pass '0' as strict mode
# virsh numatune r71 0 1

# virsh numatune r71
numa_mode      : strict
numa_nodeset   : 1

2. pass '1' as preferred mode
# virsh numatune r71 1 1

# virsh numatune r71
numa_mode      : preferred
numa_nodeset   : 1

3. pass '2' as interleave mode
# virsh numatune r71 2 1

# virsh numatune r71
numa_mode      : interleave
numa_nodeset   : 1

4. pass invalid number
# virsh numatune r71 3 1
error: Unable to change numa parameters
error: invalid argument: unsupported numatune mode: '3'

# virsh numatune r71 -1 1
error: Unable to change numa parameters
error: invalid argument: unsupported numatune mode: '-1'

So change the status to VERIFIED.

Comment 5 Jincheng Miao 2014-11-19 09:23:22 UTC
In addition, the doc has been updated:
# virsh help numatune
...
    [--mode] <string>  NUMA mode, one of strict, preferred and interleave 
or a number from the virDomainNumatuneMemMode enum
...

Comment 7 errata-xmlrpc 2015-03-05 07:33:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHSA-2015-0323.html