Bug 108576 - redhat-config-network and kudzu fight over wireless adaptor.
redhat-config-network and kudzu fight over wireless adaptor.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kudzu (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2003-10-30 05:36 EST by Ali-Reza Anghaie
Modified: 2014-03-16 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 09:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv of the subject system.. (8.41 KB, text/plain)
2003-10-30 05:36 EST, Ali-Reza Anghaie
no flags Details
hwconf post install (3.52 KB, text/plain)
2004-02-24 00:33 EST, Tom Diehl
no flags Details
ifcfg-eth0 as set by anaconda (107 bytes, text/plain)
2004-02-24 00:34 EST, Tom Diehl
no flags Details
ifcfg-eth1 post install (109 bytes, text/plain)
2004-02-24 00:35 EST, Tom Diehl
no flags Details
Modules.conf post install (271 bytes, text/plain)
2004-02-24 00:36 EST, Tom Diehl
no flags Details
kudzu -p in rl 1 per your request (3.49 KB, text/plain)
2004-02-24 09:10 EST, Tom Diehl
no flags Details

  None (edit)
Description Ali-Reza Anghaie 2003-10-30 05:36:08 EST
Description of problem:

Using rhcn to configure a "Harris Semiconductor|Prism 2.5 Wavelan chipset":

vendorId: 1260
deviceId: 3873
subVendorId: 1668
subDeviceId: 0406

I got a wireless card that tried to limp to life. What happens though is on the
next reboot kudzu decides this card has been removed but it hasn't. It turns out
that somehoe an entry for a ~second~ Harris adaptors gets put in
/etc/sysconfig/hwconf. The entry is ~exactly~ the same as the first (should that
even be possible?).

Run rhcn again, and sure enough you see a Prism 2.5 eth1 and an 'orinoco' eth2.
Remove the device, rerun kudzu quietly, nothing.. still there. Reboot and choose
'remove' in Kudzu and it's gone from hwconf until you run rhcn again, then the
eth2 adaptor appears again and on reboot the whole cycle starts again.

I didn't want to continuously look and reboot but to resolve the issue after a
few reboots I had to:

- Manually remove duplicate block from hwconf. Re-run kudzu.

- Manually remove ~both~ eth1 and eth2 from rhcn. Check hwconf, make sure it
wasn't changed (which I wouldn't expect rhcn would do).

- Re-run kudzu, everything still ok.

- Reboot, everything ok.

Then I configured the interface by hand and this problem didn't happen again. So
that's why I'm filing it against rhcn, I ~think~ that is what confused matters
by trying to establish an eth2 (but how would it do it without an entry in
hwconf ~already~?).

So I'm not sure what starts it but somehow kudzu and rhcn end up with two
interfaces and kudzu wants to remove it (but never can, it comes back) and rhcn
wants to configure it (but obviously can't).


Version-Release number of selected component (if applicable):

kernel-2.4.21-4.EL
redhat-config-network-1.2.58-1
kudzu-1.1.21-1

How reproducible:

Each time I tried.

Steps to Reproduce:
1. (read above description)
    
Actual results:


Expected results:


Additional info:

class: NETWORK
bus: PCI
detached: 0
device: eth1
driver: orinoco_pci
desc: "Harris Semiconductor|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 1668
subDeviceId: 0406
pciType: 1
pcibus:  2
pcidev:  2
pcifn:  0

Will attach lspci -vvv too....
Comment 1 Ali-Reza Anghaie 2003-10-30 05:36:48 EST
Created attachment 95601 [details]
lspci -vvv of the subject system..
Comment 2 Harald Hoyer 2003-10-30 09:29:11 EST
the problem seems to be kudzu and the duplicated block.... 
Comment 3 Bill Nottingham 2004-02-04 01:33:36 EST
Please try
http://people.redhat.com/notting/kudzu/kudzu-1.1.22.1-1.i386.rpm ; it
has the known bogons fixed.
Comment 4 Godmar Back 2004-02-19 01:19:38 EST
Problem still exists with 1.1.36-1.  See bug 108178
Comment 5 Tom Diehl 2004-02-24 00:33:15 EST
Created attachment 97971 [details]
hwconf post install
Comment 6 Tom Diehl 2004-02-24 00:34:47 EST
Created attachment 97972 [details]
ifcfg-eth0 as set by anaconda
Comment 7 Tom Diehl 2004-02-24 00:35:59 EST
Created attachment 97973 [details]
ifcfg-eth1 post install
Comment 8 Tom Diehl 2004-02-24 00:36:52 EST
Created attachment 97974 [details]
Modules.conf post install
Comment 9 Tom Diehl 2004-02-24 00:44:00 EST
The above 4 attachments are from the first boot after a fresh install.
I updated kudzu to
http://people.redhat.com/notting/kudzu/kudzu-1.1.22.1-1.i386.rpm
during the %post of the kickstart installation. Upon the first boot
kudzu wants to rm one of the nic's config. If I tell it "do nothing"
the interface comes up and works. With kudzu-1.1.21-1.i386.rpm the
machine would need to be rebooted twice to get the nic in a usable state.
Comment 10 Bill Nottingham 2004-02-24 00:58:14 EST
Is one of them cardbus? (It doesn't look like it, but making sure...)
Comment 11 Godmar Back 2004-02-24 01:01:50 EST
not for me.
Comment 12 Tom Diehl 2004-02-24 01:18:42 EST
Another note. I rebooted the machine again and told kudzu to delete
the configuration and then install the config again. It deleted eth1
and relabeled it as eth2 and would not come up. I rebooted 1 more time
and let kudzu reconfigure the nic again. This time it reconfigured the
nic as eth1 and it works. I have the modules.conf, hwconf, and
ifcfg-eth* if it is useful to you let me know and I will post it. 

Not sure if the card bus comment is for me or not but no it is not
cardbus.
Comment 13 Bill Nottingham 2004-02-24 01:27:55 EST
tdiehl@rogueind.com: could you attach the output of 'kudzu -p' when in
single-user mode?
Comment 14 Tom Diehl 2004-02-24 09:10:53 EST
Created attachment 97994 [details]
kudzu -p in rl 1 per your request
Comment 15 Brian Long 2004-06-16 14:26:41 EDT
I wonder if this is related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=126147
which I just logged.
Comment 16 Bill Nottingham 2004-08-27 18:32:40 EDT
Please try the kudzu-1.1.25-1 packages at:

http://people.redhat.com/kudzu/

Comment 17 Bill Nottingham 2004-08-27 18:33:38 EDT
Make that 1.1.22.5-1. *sigh*.
Comment 18 Tom Diehl 2004-08-28 20:55:23 EDT
Presumably you really meant:
http://people.redhat.com/notting/kudzu/RHEL3/kudzu-1.1.22.5-1.i386.rpm :-)
It appears to have fixed my problem. I even rm'd the card from the
machine rebooted it rm'd the config, and reinstalled everything. All
appears to work as it should.

Since I was not the OP I cannot change the status of this. In addition
my problem was with wired NICs not wireless so I do not know if this
is fixed for everyone.

Thanks for the fix,

Tom

Comment 19 Tom Diehl 2004-08-29 23:37:15 EDT
Is 123571 really supposed to be secret or is this an error? Since It
is tied to this bug I am courious what it is.
Comment 20 Bill Nottingham 2004-08-29 23:39:57 EDT
It's an internal tracking bug.
Comment 21 Jeff Needle 2004-08-31 10:29:29 EDT
Changing to another double secret internal tracking bug :-).
Comment 23 John Flanagan 2004-12-21 09:21:57 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-509.html

Note You need to log in before you can comment on or make changes to this bug.