Bug 1086032 - If another network has the "required" flag a new host will fail and timeout
Summary: If another network has the "required" flag a new host will fail and timeout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-hosted-engine-setup
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.1
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard: integration
Depends On: 1158418
Blocks: 1192937
TreeView+ depends on / blocked
 
Reported: 2014-04-10 00:35 UTC by Andrew Lau
Modified: 2015-02-16 09:35 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.1_rc1
Doc Type: Bug Fix
Doc Text:
Cause: An additional required network has been added after deploying the first host. Consequence: hosted-engine-setup fails trying to deploy an additional host Fix: Adding the host in a non-operational status. Printing a hint for the user that needs to configure network bindings for that host.
Clone Of:
Environment:
Last Closed: 2015-01-21 16:04:14 UTC
oVirt Team: ---


Attachments (Terms of Use)
ovirt-hosted-engine-setup (363.05 KB, text/plain)
2014-10-28 16:05 UTC, Simone Tiraboschi
no flags Details
vdsm (1.70 MB, text/plain)
2014-10-28 16:09 UTC, Simone Tiraboschi
no flags Details
supervdsm (45.53 KB, text/plain)
2014-10-28 16:10 UTC, Simone Tiraboschi
no flags Details
connectivity (1.01 KB, text/plain)
2014-10-28 16:11 UTC, Simone Tiraboschi
no flags Details
host-deploy_from_hosted_engine (268.69 KB, text/plain)
2014-10-28 16:46 UTC, Simone Tiraboschi
no flags Details
host-deploy_from_webgui (270.46 KB, text/plain)
2014-10-28 16:47 UTC, Simone Tiraboschi
no flags Details
engine (164.59 KB, text/plain)
2014-10-28 16:51 UTC, Simone Tiraboschi
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 34789 master MERGED packaging: setup: enforcing required networks configuration additional hosts Never
oVirt gerrit 34834 master MERGED packaging: setup: configuring cluster CPU type only on the first host Never
oVirt gerrit 34894 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: configuring cluster CPU type only on the first host Never
oVirt gerrit 34939 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: enforcing required networks configuration additional hosts Never
oVirt gerrit 36926 ovirt-hosted-engine-setup-1.2 MERGED packaging: setup: Prompt if host non-operational Never

Description Andrew Lau 2014-04-10 00:35:06 UTC
Description of problem:
When adding a new host to the hosted-engine setup, if there is another network in the cluster with the required flag - which I believe is default for any new networks required.

The new host will stay in and eventually time out. This is because the engine has come up within the engine as non-operational as it doesn't meet the cluster's network requirements. (ie. a required network isn't configured on the host)
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...
[ INFO  ] Still waiting for VDSM host to become operational...

Logging into the engine and assigning the correct networks will let the host come up as operational and succeed the install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install first host
2. Configure a new network in the Default cluster
3. Attempt to bring up a second host

Actual results:
Will timeout

Expected results:
Should let the host be successfully installed and let the user add the networks later. Possibly have it join the cluster in maintenance mode to avoid the issue?

Additional info:

Comment 1 Simone Tiraboschi 2014-10-28 16:00:52 UTC
Reproduced, I'm attaching the relevant log files as a reference for further investigation.

Comment 2 Simone Tiraboschi 2014-10-28 16:05:01 UTC
Created attachment 951442 [details]
ovirt-hosted-engine-setup

ovirt-hosted-engine-setup

Comment 3 Simone Tiraboschi 2014-10-28 16:09:34 UTC
Created attachment 951444 [details]
vdsm

vdsm

Comment 4 Simone Tiraboschi 2014-10-28 16:10:29 UTC
Created attachment 951445 [details]
supervdsm

supervdsm

Comment 5 Simone Tiraboschi 2014-10-28 16:11:25 UTC
Created attachment 951447 [details]
connectivity

connectivity

Comment 6 Simone Tiraboschi 2014-10-28 16:45:19 UTC
It's failing also trying to add the same host from the oVirt web admin gui.

Comment 7 Simone Tiraboschi 2014-10-28 16:46:33 UTC
Created attachment 951451 [details]
host-deploy_from_hosted_engine

host-deploy
Firt run: from hosted-engine

Comment 8 Simone Tiraboschi 2014-10-28 16:47:31 UTC
Created attachment 951453 [details]
host-deploy_from_webgui

host-deploy
second run: from oVirt web admin gui

Comment 9 Simone Tiraboschi 2014-10-28 16:51:08 UTC
Created attachment 951454 [details]
engine

engine

Comment 10 Sandro Bonazzola 2015-01-15 14:36:08 UTC
This is an automated message: 
This bug should be fixed in oVirt 3.5.1 RC1, moving to QA

Comment 11 Sandro Bonazzola 2015-01-21 16:04:14 UTC
oVirt 3.5.1 has been released. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.