Bug 1086073 - libsolv-0.6.0 update
Summary: libsolv-0.6.0 update
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1086981 1087929 1087972 1088119 1088874 1088962 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-10 04:17 UTC by Greg`
Modified: 2014-06-21 03:57 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-21 03:57:14 UTC


Attachments (Terms of Use)

Description Greg` 2014-04-10 04:17:10 UTC
Description of problem: enabling the updates-testing repo an trying to grab a package to test the new libsolv refuses to work at all


Version-Release number of selected component (if applicable): libsolv-0.6.0 and DNF-0.4.20


How reproducible:always


Steps to Reproduce:
1.download the New libsolv from koji
2.then enable the updates-testing repo
3.dnf an or libsolv fails to drop down the updates-testing list of packages needed testing

Actual results:
YUM works fine for me

Expected results:
dnf should drop down the list of ( updates-testing ) Packages that need testing

Additional info: as far as it get

 [grego@localhost ~]$ sudo dnf --enablerepo=updates-testing check-update
Fedora 20 - x86_64                              1.7 MB/s |  36 MB     00:20    
Copr repo for enlightenment owned by zhevron    109 kB/s | 155 kB     00:01    
RPM Fusion for Fedora 20 - Free - Updates        54 kB/s | 277 kB     00:05    
Adobe Systems Incorporated                      2.6 kB/s | 1.8 kB     00:00    
RPM Fusion for Fedora 20 - Nonfree - Updates    396 kB/s |  73 kB     00:00    
RPM Fusion for Fedora 20 - Free                  95 kB/s | 487 kB     00:05    
Fedora 20 - x86_64 - Updates                    1.9 MB/s |  20 MB     00:10    
google-chrome                                    14 kB/s | 3.1 kB     00:00    
RPM Fousion for Fedora 20 - Nonfree               54 kB/s | 289 kB     00:05    
[grego@localhost ~]$

Comment 1 Ales Kozumplik 2014-04-10 07:26:21 UTC
Might be because the new libsolv breaks the ABI and we haven't provided a new hawkey build yet. Moving to Jan.

Comment 2 Greg` 2014-04-10 22:31:33 UTC
another issue when i tried to update google-chrome thismorning 

Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 75, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 156, in _main
    return_code, resultmsgs = base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 214, in do_transaction
    self.download_packages(downloadpkgs, self.output.progress, total_cb)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 909, in download_packages
    errors = dnf.repo.download_payloads(payloads, drpm)
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 97, in download_payloads
    targets = [pload.librepo_target() for pload in payloads]
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 278, in librepo_target
    target_dct.update(self._target_params())
  File "/usr/lib/python2.7/site-packages/dnf/repo.py", line 289, in _target_params
    ctype, csum = pkg.returnIdSum()
  File "/usr/lib/python2.7/site-packages/dnf/package.py", line 174, in returnIdSum
    (chksum_type, chksum) = self.chksum
  File "/usr/lib/python2.7/site-packages/dnf/package.py", line 52, in chksum
    return super(Package, self).chksum
AttributeError: No such checksum.

Comment 3 Adam Williamson 2014-04-14 14:51:54 UTC
this is happening 'out of the box' on current Rawhide, at least to me.

[adamw@adam doom]$ rpm -q libsolv hawkey dnf
libsolv-0.6.0-0.git05baf54.fc21.x86_64
hawkey-0.4.12-1.fc21.x86_64
dnf-0.4.20-1.fc21.noarch

Comment 4 Greg` 2014-04-14 21:56:23 UTC
Adam
.
you must update to hawkey 0.4.13 it fix's the problem

Comment 5 Ales Kozumplik 2014-04-15 07:19:41 UTC
*** Bug 1086981 has been marked as a duplicate of this bug. ***

Comment 6 Ales Kozumplik 2014-04-15 07:23:16 UTC
The update is here https://admin.fedoraproject.org/updates/hawkey-0.4.13-1.fc20

Comment 7 Honza Silhan 2014-04-16 07:56:45 UTC
*** Bug 1087972 has been marked as a duplicate of this bug. ***

Comment 8 Ales Kozumplik 2014-04-16 08:36:03 UTC
*** Bug 1088119 has been marked as a duplicate of this bug. ***

Comment 9 Ales Kozumplik 2014-04-16 09:01:44 UTC
*** Bug 1087929 has been marked as a duplicate of this bug. ***

Comment 10 Alexander Lipatov 2014-04-16 19:14:40 UTC
Another user experienced a similar problem:

After "sudo dnf clean all; sudo dnf update" I saw packages list and when I press "y" and enter - error occurs

reporter:       libreport-2.2.1
cmdline:        /usr/bin/python /bin/dnf update
executable:     /bin/dnf
kernel:         3.13.9-200.fc20.x86_64
package:        dnf-0.4.20-1.fc20
reason:         package.py:52:chksum:AttributeError: No such checksum.
runlevel:       N 5
type:           Python
uid:            0

Comment 11 collura 2014-04-17 05:43:40 UTC
regarding comment#2 and comment#4:

using yum to update to 

  hawkey-0.4.13-1.fc20.x86_64
  python-hawkey-0.4.13-1.fc20.x86_64

fixed the dnf errors for me as well

thanks :')

Comment 12 Greg` 2014-04-17 05:49:46 UTC
(In reply to collura from comment #11)
> regarding comment#2 and comment#4:
> 
> using yum to update to 
> 
>   hawkey-0.4.13-1.fc20.x86_64
>   python-hawkey-0.4.13-1.fc20.x86_64
> 
> fixed the dnf errors for me as well
> 
> thanks :')

all users must use YUM to update to it . then DNF will work again

Comment 13 Lukas Slebodnik 2014-04-17 08:03:44 UTC
(In reply to Greg` from comment #12)
> (In reply to collura from comment #11)
> > regarding comment#2 and comment#4:
> > 
> > using yum to update to 
> > 
> >   hawkey-0.4.13-1.fc20.x86_64
> >   python-hawkey-0.4.13-1.fc20.x86_64
> > 
> > fixed the dnf errors for me as well
> > 
> > thanks :')
> 
> all users must use YUM to update to it . then DNF will work again

you can use rpm for updating hawkey.

Comment 14 Ales Kozumplik 2014-04-17 12:31:00 UTC
*** Bug 1088874 has been marked as a duplicate of this bug. ***

Comment 15 Radek Holy 2014-04-18 08:01:13 UTC
*** Bug 1088962 has been marked as a duplicate of this bug. ***

Comment 16 Jan Synacek 2014-04-18 09:15:39 UTC
Seems to be working on rawhide, thanks!

Comment 17 Greg` 2014-06-20 12:21:57 UTC
libsolv-0.6.3 is out . would it Benefit Fedora to update to latest upstream https://github.com/openSUSE/libsolv/blob/master/VERSION.cmakeversion?

Comment 18 Adam Williamson 2014-06-21 03:57:14 UTC
Well, I'm sure that'll happen, but it's not relevant to this bug report...the update is stable for F20 and obviously for Rawhide, so I think we can close this now.


Note You need to log in before you can comment on or make changes to this bug.