Bug 1086199 - PackageKit-gstreamer-plugin: Bogus "Requires: gstreamer" (should be "gstreamer1" or just rely on the autoreq)
Summary: PackageKit-gstreamer-plugin: Bogus "Requires: gstreamer" (should be "gstreame...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: depchain
TreeView+ depends on / blocked
 
Reported: 2014-04-10 10:51 UTC by Kevin Kofler
Modified: 2014-04-29 15:56 UTC (History)
4 users (show)

Fixed In Version: PackageKit-0.9.1-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-29 15:56:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Kofler 2014-04-10 10:51:18 UTC
Description of problem:
PackageKit-gstreamer-plugin in Rawhide is built against GStreamer 1, but still has a hardcoded "Requires: gstreamer" that drags in 0.10.

Version-Release number of selected component (if applicable):
PackageKit-gstreamer-plugin-0.9.1-1.fc21

How reproducible:
Always

Steps to Reproduce:
1. Install PackageKit-gstreamer-plugin.

Actual results:
GStreamer 0.10 is required.

Expected results:
GStreamer 0.10 is not required anymore.

Additional info:
The BuildRequires were changed to gstreamer1-* on March 24, but the Requires was apparently forgotten.

Comment 1 Richard Hughes 2014-04-10 15:52:54 UTC
Yup, can you please just fix this in the spec and I'll do a build/update for the next PK release. Thanks!

Comment 2 Kevin Kofler 2014-04-29 15:56:34 UTC
This has been fixed since 0.9.1-2.


Note You need to log in before you can comment on or make changes to this bug.