Bug 1086355 - repository create form sending up empty string which pulp errors on as feed
Summary: repository create form sending up empty string which pulp errors on as feed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
urgent vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Katello QA List
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-10 16:31 UTC by Tom McKay
Modified: 2019-09-26 13:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:08:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 5142 None None None 2016-04-22 15:49:29 UTC

Description Tom McKay 2014-04-10 16:31:16 UTC
Page 11 Section 3.3 Step 6 - Clicking Save gives brief spinner but does not leave page. No error displayed in UI.

    The 'feed' form param is getting sent as "" (empty string). This is reproducible by entering a URL value in the form and then clearing it. (The step doesn't mention URL so I pasted the previous path there before deleting it before form submission. No error in UI. Can see error state in /foreman_tasks/dynflow (See @jsherrill for debug)

Comment 1 Tom McKay 2014-04-10 16:32:02 UTC
Created redmine issue http://projects.theforeman.org/issues/5142 from this bug

Comment 2 RHEL Product and Program Management 2014-04-10 16:54:57 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Justin Sherrill 2014-04-10 18:30:27 UTC
https://github.com/Katello/katello/pull/3969

Comment 5 Bryan Kearney 2014-04-23 11:39:49 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5142 has been closed

Comment 7 Corey Welton 2014-05-06 20:46:08 UTC
Verified in Satellite-6.0.3-RHEL-6-20140430.4 -- however, I'm thinking we still should not be able to save a repo with no repourl, or not be able to initiate a sync on such a repo.  This is a separate bz I will enter afterwards.  However, for all intents and purposes, the behavior seen here is fixed.

Comment 8 Bryan Kearney 2014-07-02 14:08:15 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Comment 9 Bryan Kearney 2014-07-02 14:09:34 UTC
This was delivered in 6.0.3, the Beta version of Satellite 6.0


Note You need to log in before you can comment on or make changes to this bug.