Bug 108643 - pkgorder script crashes when run because it tries to find a file in an absolute path instead of a relative path
pkgorder script crashes when run because it tries to find a file in an absolu...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 16:15 EST by Razvan Corneliu C.R. VILT
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-02 20:17:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Razvan Corneliu C.R. VILT 2003-10-30 16:15:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:
running pkgorder ./i386/ i386 > ./pkgorder.txt
gives the a file not found error for:
/RedHat/base/comps.xml
That is an absolute path. It should be
/$PATH_TO_DISTRIB_TREE/RedHat/base/comps.xml instead.

The exec problem is in the /usr/lib/anaconda/hdrlist.py at line 882, where, due
to my lack of python knowledge and time, to make the script work I had to write
the path like below:
file =
urllib2.urlopen("file:///mnt/distrib/linux360-1.0test0/i386/RedHat/base/comps.xml")

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a distribution tree!
2. start building it.
3. At pkgorder the crash occurs.
    

Actual Results:  The script crashes.

Expected Results:  The script should have opened the "RedHat/base/comps.xml"
file instead of the /RedHat/base/comps.xml.
Comment 1 Brent Fox 2003-10-30 16:44:13 EST
Looks like the "RedHat" should be replaced with "Fedora"
Comment 2 Razvan Corneliu C.R. VILT 2003-10-30 21:53:22 EST
I already created a sym-link from RedHat to Fedora because anaconda wanted
RedHat and not fedora. Weird.
Comment 3 Jeremy Katz 2003-11-02 20:17:45 EST
You need to add another argument to your pkgorder invocation, eg
 pkgorder ./i386/ i386 Fedora

Note You need to log in before you can comment on or make changes to this bug.