Bug 108646 - Message Fonts Prefs Gives Undefined Results
Message Fonts Prefs Gives Undefined Results
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 16:20 EST by Thomas J. Baker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-02 22:19:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2003-10-30 16:20:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027
Galeon/1.3.10

Description of problem:
In the Tools->Settings dialog, under Mail Preferences, there is a Message Fonts
section with a checkbox for "Use the same fonts as other applications". I take
this to mean use the same fonts I've picked from the Fonts prefernce but this
does not seem to be the case. It appears to be using some other fonts when this
box is checked, at least for the Terminal font. I think it might be using Monospace.

Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1. set fonts in font preferences
2. change the preference in above stated dialog
3.
    

Actual Results:  See the wrong fonts being displayed.

Expected Results:  See the correct fonts being displayed.

Additional info:

I would have suspected my years-old evolution prefs to maybe be the cause but
under a fresh evolution directory it also happens.
Comment 1 Jeremy Katz 2003-11-02 22:19:49 EST
The default font for in the message text is going to follow the
terminal font (as "terminal" is used instead of "monospace").  Email
is showed using a monospace font by default because otherwise, text
mail gets weird, especially with column wrapping and the like.
Comment 2 Thomas J. Baker 2003-11-03 08:07:35 EST
I realize that. What I'm saying is that in the font prefs, I have vera
mono selected as my terminal font (which works with gnome-terminal)
and it's not being used in evolution when the "use same font as other
applications" is checked. 

Note You need to log in before you can comment on or make changes to this bug.