Bug 108647 - LVM fails to be recognized after creation
Summary: LVM fails to be recognized after creation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Heinz Mauelshagen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-30 21:27 UTC by Jp Robinson
Modified: 2008-03-17 16:21 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 16:21:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jp Robinson 2003-10-30 21:27:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Description of problem:
I installed my machine with lvm as the "/" partition and it seemed to go ok, but
when it rebooted, it kernel paniced mounting the root partition. 

I tried to investigate via rescue mode, but it had trouble mounting it as well,
but this may be due to using a rh9 cd1 to do rescue (install of AS 3 was network). 

So I reinstalled and made a "/data" partition on lvm, and on first boot, it also
failed to be recognized. I commented it out of fstab and tried to run "vgscan"
to see if it was even seeing the partition. vgscan fails with:

vgscan -- reading all physical volumes (this may take a while...)
vgscan -- found active volume group "Volume00"
vgscan -- ERROR "vg_read_with_pv_and_lv(): current PV" can't get data of volume
group "Volume00" from physical volume(s)
vgscan -- "/etc/lvmtab" and "/etc/lvmtab.d" successfully created
vgscan -- WARNING: This program does not do a VGDA backup of your volume group
 
To tell if this was an installer problem, I tried to follow the man page example
to create an lvm volume. This worked fine, formatted, mounted, etc. But failed
on a subsequent vgscan as well. 


As an additional note, I have lvm on a seperate machine, and it is working
perfectly. Also running AS 3.

Let me know any additional information you may need.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install with lvm
2.fail to recognize on boot

1. Create new lvm volume
2. fail to recognize on boot.
aLways fails on this machine.

    

Additional info:

Comment 2 Heinz Mauelshagen 2004-04-22 14:32:24 UTC
In order to activate root on LV, the initrd must run "vgscan;vgchange
-ay" successfully, which can fail if it is too small or has too few
inodes and the proper root fs switch must happen.
Reassigned to mkinitrd owner.

Comment 3 RHEL Product and Program Management 2007-10-19 19:33:26 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.