Bug 108672 - Xcursors do not work properly with Xinerama enabled
Xcursors do not work properly with Xinerama enabled
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 20:09 EST by Donald Sharpe
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config File (10.76 KB, text/plain)
2003-11-03 10:06 EST, Donald Sharpe
no flags Details
XFree log with Xinerama enabled. (53.59 KB, text/plain)
2003-11-03 10:08 EST, Donald Sharpe
no flags Details
XF86Config with no Xinerama (10.77 KB, text/plain)
2003-11-03 10:53 EST, Donald Sharpe
no flags Details
XFree86 log with no xinerama (53.38 KB, text/plain)
2003-11-03 10:53 EST, Donald Sharpe
no flags Details

  None (edit)
Description Donald Sharpe 2003-10-30 20:09:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.1.4322)

Description of problem:
When xinerama is enabled, cursors revert to a non-animated black and white 
cursor. 

Version-Release number of selected component (if applicable):
XFree86-4.3.0-42

How reproducible:
Always

Steps to Reproduce:
1.Enable xinerama
2.Pick an animated cursor
3.
    

Actual Results:  After rebooting/relogin cursor appears in black and white 
with no animation.

Expected Results:  Cursor should be in color and animated.

Additional info:
Comment 1 Mike A. Harris 2003-11-03 09:41:00 EST
> 2.Pick an animated cursor

Which specific animated cursor theme are you picking?  I need
to have specific details so I can reproduce this with the exact
same setup you are using.

I need to have copies of your XFree86 config file and X server log
file from using X with Xinerama disabled, and also a copy of each
file with Xinerama enabled.  Please attach all 4 files as
uncompressed individual file attachments using the link below.
Comment 2 Mike A. Harris 2003-11-03 09:49:04 EST
Also, what method are you using to pick the particular cursor theme?
There are 3 different ways to change the cursor theme.
Comment 3 Donald Sharpe 2003-11-03 10:05:22 EST
About my setup:
I have 3 NVidia Geforce 2 MX cards. All using the nvidia driver.
I have tried the nv driver and it had the same results. 

To change the cursor, I am adding the following in my .Xresources file
Xcursor.theme: Bluecurve

Will attach files shortly...
Comment 4 Donald Sharpe 2003-11-03 10:06:11 EST
Created attachment 95671 [details]
XF86Config File
Comment 5 Donald Sharpe 2003-11-03 10:08:48 EST
Created attachment 95672 [details]
XFree log with Xinerama enabled.
Comment 6 Donald Sharpe 2003-11-03 10:53:00 EST
Created attachment 95674 [details]
XF86Config with no Xinerama
Comment 7 Donald Sharpe 2003-11-03 10:53:34 EST
Created attachment 95676 [details]
XFree86 log with no xinerama
Comment 8 Gérard Milmeister 2003-11-07 06:56:07 EST
Same problem here on FC1.
NVIDIA driver 4496 and Xinerama.
Comment 9 Gérard Milmeister 2003-11-07 13:14:46 EST
I switched to TwinView instead of Xinerama, and the problem disappears.
TwinView has its own issues though.
Comment 10 Mike A. Harris 2003-11-09 04:20:42 EST
The Nvidia binary drivers are not supported by Red Hat at all.
The file attachments in this bug report show that Nvidia binary
drivers are being used.  While you've indicated that this problem
also occurs when using the "nv" driver, you have not attached
any information to the report with which that can be verified,
or investigated.

You should also note, that the "nv" driver does not support
Xinerama, so if you require dualhead support you really have no
option other than using the unsupported Nvidia binary drivers,
and seeking technical support directly from Nvidia.  You may
wish to report the issue directly to XFree86.org as well if you
like at http://bugs.xfree86.org where the "nv" driver maintainer
can give you a more up to date official response as to future
driver support plans for "nv".

Comment 11 Mike A. Harris 2003-11-09 04:20:59 EST

*** This bug has been marked as a duplicate of 73733 ***
Comment 12 Donald Sharpe 2003-11-09 19:11:06 EST
I'm running Gentoo Linux on another system with the exact same
hardware/driver configuration. 
NVidia binary drivers, multiple NVidia Cards, and X 4.3.0. Cursors
work just fine there. Makes me think it is not soully a driver related
problem.
Comment 13 Mike A. Harris 2003-11-14 21:09:10 EST
It may or may not be a driver problem, however it is an unsupported
driver, and thus an unsupported problem - unless it is reproduceable
on the distribution supplied and supported drivers.  You'll need
to seek support for the driver from Nvidia, or XFree86.org, or
debug the problem and if you indeed find the bug to be in the
X server that only affects one single video driver, and is not a bug
in the driver itself, feel free to supply a patch that fixes it and
reopen the bug report for review for consideration in future
updates.

Comment 14 David Gillies 2004-02-19 00:57:15 EST
I'm currently running Redhat 9.0 with Xinerama running on an IBM
ThinkPad T40, which had an ATI Radeon. This uses the built in XFree86
driver and I'm having the same issue as well.

It appear that the chosen xcursor is being used, but it is being
displayed in black and white, not full colour.
Comment 15 Toms Baugis 2004-04-03 11:46:31 EST
I had same problems (no cursors in xinerama as with nv, so nvidia
driver). Good news are, that in Fedora Core 2 Test2, with built in
(Xorg's?)-XFree86, cursors show up properly. Also gnome font
preferences now display on second monitor properly.

Still - could not manage to get running nvidia's closed source drivers.
Comment 16 Red Hat Bugzilla 2006-02-21 13:59:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.