This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 108675 - impossible to focus dictionnary applet entry
impossible to focus dictionnary applet entry
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 21:34 EST by Dams
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 16:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-10-30 21:34:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.4.1) Gecko/20031027
Galeon/1.3.10

Description of problem:
I cannot focus the dictionnary applet entry by moving the mouse upon the entry
nor by clicking into it.

If i press Ctrl-Alt-Tab until the panel is focused then it's okay and i can fill
the entry.

I think it's a bug in metacity sloppy focus behaviour, because if i use the
click-to-focus, the applet is rightly focused when clicking on it.


Version-Release number of selected component (if applicable):
metacity(0:2.6.3-1).i386 gnome-panel(0:2.4.0-3)

How reproducible:
Always

Steps to Reproduce:
1. Add the dictionnary applet to a gnome-panel
2. Configure metacity not to use click-to-focus
3. Try to enter a word in the entry of the applet


Actual Results:  keyboard event is sent to the focused window (which is not the
panel), and clicking in the entry doesnt help.
Comment 1 P Jones 2003-11-10 13:44:10 EST
The same bug exists for Command Line applet.
Comment 2 Osmo Laitinen 2004-01-16 09:19:50 EST
I can confirm this same behaviour with command line applet.
Comment 3 Mark McLoughlin 2004-02-20 10:15:28 EST
This is a metacity bug - moving there ...
Comment 4 Elijah Newren 2004-05-21 15:13:56 EDT
Mark: Did you actually move it?  (If so, do you remember the bug
number so I can mark duplicates there?)

Also, this is a duplicate of bug 108674 in redhat bugzilla and bug
115072 in gnome bugzilla.  This bug has since been fixed.

Note You need to log in before you can comment on or make changes to this bug.