Bug 1086889 - empty modify returns LDAP_INVALID_DN_SYNTAX
Summary: empty modify returns LDAP_INVALID_DN_SYNTAX
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Sankar Ramalingam
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-11 18:35 UTC by Noriko Hosoi
Modified: 2020-09-13 21:02 UTC (History)
5 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1086890 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:54:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 1104 0 None None None 2020-09-13 21:02:52 UTC
Red Hat Product Errata RHBA-2014:1385 0 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2014-10-14 01:27:42 UTC

Description Noriko Hosoi 2014-04-11 18:35:43 UTC
Description of problem:
Doing an empty modify operation returns LDAP_INVALID_DN_SYNTAX to the client. It should be allowed with no errors.

Version-Release number of selected component (if applicable):


How reproducible:
ldapbertest

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Amita Sharma 2014-06-12 08:00:26 UTC
Hi Noriko,

Is there any test case already for this in ldapbertest?

Thanks,
Ami

Comment 2 Noriko Hosoi 2014-06-12 16:41:08 UTC
Hi Ami,

It seems if ldapbertest case 83 and 84 pass, this bug is verified.
> ldapbertest/ldapbertest.sh:# Test cases 83 and 84 fail due to https://fedorahosted.org/389/ticket/47772

Comment 4 Amita Sharma 2014-07-11 08:58:33 UTC
[root@dhcp201-155 ~]# rpm -qa | grep 389
389-admin-debuginfo-1.1.34-1.el6.x86_64
389-ds-base-debuginfo-1.2.11.15-36.el6.x86_64
389-adminutil-1.1.17-1.el6.x86_64
389-ds-base-libs-1.2.11.15-38.el6.x86_64
389-adminutil-debuginfo-1.1.17-1.el6.x86_64
389-ds-base-1.2.11.15-38.el6.x86_64
389-console-1.1.7-1.el6.noarch

http://dhcp201-155.englab.pnq.redhat.com/qa/output/Linux/20140711-042130/ldapbertest/ldapbertest.run.out.31593

Executing test test083ModifyNoMods

Completed test test083ModifyNoMods
######################################################################
tp083: expect=0 actual=0
PASS
######################################################################

Executing test test084ModifyEmptyMods

Completed test test084ModifyEmptyMods
######################################################################
tp084: expect=0 actual=0
PASS

Hence VERIFIED

Comment 5 errata-xmlrpc 2014-10-14 07:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html


Note You need to log in before you can comment on or make changes to this bug.