Bug 108691 - up2date package loss after crash
up2date package loss after crash
Status: CLOSED DUPLICATE of bug 106514
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-31 03:20 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-10-31 03:20:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Firebird/0.7

Description of problem:
I used up2date 10-30-2003 and it had to update about 20 packages.

During it installation of kernel-source up2date died because it could not
install the package. The problem now is, that all packages that where to be
installed after kernel-source are de-installed!

Now, on my system openoffice and, of course, kernel-source are missing! There
were another 10 packages that might not be there, but unfortunately I updated in
a console window so there is no scrollback buffer available to find out what
other packages are missing.

I can live with this happening during the test-phase of fedora, but I think this
is a showstopper for production!

Michael

Version-Release number of selected component (if applicable):
up2date-4.1.14-2

How reproducible:
Didn't try

Steps to Reproduce:
1. create a package that exits with an error together with some good packages
2. up2date --update 
3. look at rpm-database, all packages that were to be installed after the bad
one should be missing
    

Expected Results:  At least there should be an error message, that packages are
missing now. Best would have been to rollback the install / or to continue
installation and then to show an error message that the defective package could
not be installed

Additional info:
Comment 1 Alexandre Oliva 2003-10-31 08:28:01 EST
Not exactly the same bug, but it's a symptom of the same underlying problem. 
Too bad it's a WONTFIX :-(

*** This bug has been marked as a duplicate of 106514 ***
Comment 2 Paul W. Frields 2003-10-31 11:10:49 EST
This looks like a closer relation to my bug #108652 than the one it's been
marked as duplicating here.
Comment 3 Alexandre Oliva 2003-10-31 12:12:54 EST
Well, it's two bugs: (i) up2date didn't sanity-check before handing packages to
the rpm transaction (108652), and (ii) rpm transaction failed and removed
packages (106514).  Unfortunately, it can only be a dup of one bug in bugzilla.
 And then, since it's a dup, it doesn't matter all that much anyway.
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:35 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.