Bug 108699 - Unkown error reported when starting program
Summary: Unkown error reported when starting program
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-31 10:54 UTC by Tomas Edwardsson
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-07 10:35:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As requested. (147.87 KB, text/plain)
2003-11-13 15:44 UTC, Tomas Edwardsson
no flags Details
redhat-config-httpd.strace.f (244.33 KB, text/plain)
2003-11-13 15:45 UTC, Tomas Edwardsson
no flags Details

Description Tomas Edwardsson 2003-10-31 10:54:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031022
Firebird/0.7

Description of problem:
I'm including usermode version since I think it might be relevant.

When running redhat-config-httpd I get a window that says "Unknown error.". But
if I run /usr/share/redhat-config-httpd/redhat-config-httpd there is no problem,
the configuration wizard starts.

This does not seem to be a problem with other redhat-config-* programs (tries
redhat-config-network and redhat-config-mouse).

Also it might be relevant that I'm using an Icelandic locale although I've tried
to set LANG=C and it still returns the error.

Version-Release number of selected component (if applicable):
redhat-config-httpd-1.1.0-5 usermode-1.69-1

How reproducible:
Always

Steps to Reproduce:
1. Run /usr/bin/redhat-config-mouse
2. Try running usr/share/redhat-config-httpd/redhat-config-httpd and it works.

Additional info:

Comment 1 Nalin Dahyabhai 2003-11-13 15:18:02 UTC
I can't reproduce this here.

Please run
  which redhat-config-httpd
  strace -s128 -f -o redhat-config-httpd.strace.f redhat-config-httpd
  strace -s128    -o redhat-config-httpd.strace   redhat-config-httpd
and attach the output of "which" and the contents of the generated
redhat-config-httpd.strace and redhat-config-httpd.strace.f files to
this bug report?  That may shed some light on what's going on.

Comment 2 Tomas Edwardsson 2003-11-13 15:44:46 UTC
Created attachment 95945 [details]
As requested.

Comment 3 Tomas Edwardsson 2003-11-13 15:45:53 UTC
Created attachment 95946 [details]
redhat-config-httpd.strace.f

Comment 4 Tomas Edwardsson 2003-11-13 15:46:51 UTC
[root@tommilap root]# which redhat-config-httpd
/usr/bin/redhat-config-httpd


Comment 5 Tomas Edwardsson 2003-11-13 15:48:33 UTC
Steps to Reproduce is wrong, you should of course run
redhat-config-httpd not redhat-config-mouse.

Comment 6 Tomas Edwardsson 2003-11-13 15:50:08 UTC
I'm not sure if this is a usermode bug so I moved the bug over there.

lrwxrwxrwx    1 root     root           13 okt 31 10:18
/usr/bin/redhat-config-httpd -> consolehelper


Comment 7 Nalin Dahyabhai 2003-11-13 16:32:38 UTC
The strace without -f shows that userhelper exited with exit code 255,
which is an most likely an unexpected error.  The strace with -f
indicates that /etc/security/console.apps/redhat-config-httpd doesn't
exist.

Can you run 'rpm -V redhat-config-httpd' to check for a
possibly-messed-up installation of the redhat-config-httpd package?

Comment 8 Tomas Edwardsson 2003-11-14 12:49:26 UTC
[root@tommilap root]# rpm -V redhat-config-httpd
....L... c /etc/pam.d/redhat-config-httpd
....L... c /etc/security/console.apps/redhat-config-httpd


lrwxrwxrwx    1 root     root           10 okt  1 13:12
/etc/security/console.apps/redhat-config-httpd -> apacheconf
lrwxrwxrwx    1 root     root           10 okt  1 13:29
/etc/pam.d/redhat-config-httpd -> apacheconf


Found a .rpmnet for both files and replaced the old ones.
redhat-config-httpd is now working.

This was an upgrade from RH 9 so I guess that's what broke it.

Comment 9 Tomas Edwardsson 2003-11-14 12:49:54 UTC
Found a .rpmnew not .rpmnet.

Comment 10 Tomas Edwardsson 2004-03-07 10:35:31 UTC
This seems to be a upgrade problem and something that might not be a
big issue. At least I'm just closing it with WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.