Bug 108705 - Idea for a better Installer - Live-Installation a la Knoppix
Summary: Idea for a better Installer - Live-Installation a la Knoppix
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-31 12:19 UTC by Christian Paratschek
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 18:41:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Paratschek 2003-10-31 12:19:59 UTC
Description of problem:

This is a feature request. I don't know if it placed correctly here, but
nonetheless, i think i have a good idea and i want to share it with the developpers:

What about including an option into the install routine to boot fedora/redhat
before installing, just like knoppix. i can imagine 2 possibilities:

1. an option to boot fedora into a fully running system in the "hit "return" to
start installation" window (like typing "live-install" to boot up the system
from cd instead of installing directly). that would be great for sysadmins like
me who want to check if fedora workes in a specific computer before installing
it. that would be a minor visible change, a nice feature for those who use it.

2. a truly 21st century installing method: insert cd 1, boot into a fully
running fedora core/redhat, that has already probed for every device on your
system (just like knoppix) and that gives you the option to see and solve
possible problems BEFORE installing the distro. imagine the install-process
being what redhat-firstboot is now - but before the damn thing is installed! :-) 

advantage: visibly better installing method vs. windows. a really cool new
feature that could be a nice selling argument. i imagine that most of the
current installation programs (e.g. anaconda) could be used in this context too.
so not too much work.

disadvantage: hmm... i don't know how difficult it is to add these
"knoppix-features" into a normal fedora/redhat-install cd. well, i am not a
programmer. could be a lot of programming problems. you gotta tell me what
reasons there are that would make this a bad idea :-)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 chip piller 2003-11-01 19:52:29 UTC
I have been very impressed with Knoppix, and I've been using every
version of Redhat since 4.2.  I booted up from the Knoppix CD, hit
return key at prompt.  Knoppix detected all of my hardware, connected
me to the internet, played startup sounds, brought up a nice graphical
desktop. And it has a bunch of great software too!

The Knoppix approach is a great way to get people started with
linux/open source.  I used to give away Redhat CD's but they were
mostly wasted.  People did not want to go through the multiple CD
install/hard drive partition/bootloader configuration routine. 

I've given away some Knoppix CD's and people have been able to try out
linux/open source in a fast simple and safe way.  Some of these people
have then gone on to do a regular linux installation.

Perhaps there could be a single CD version of fedora similar to
Knoppix.  New users could try the software out safely, learn about
it's capabilities, and then migrate to fedora core when they are ready.  

Comment 2 Jeremy Katz 2004-09-22 18:41:46 UTC
Some of the stateless linux work allows the creation of a live CD.


Note You need to log in before you can comment on or make changes to this bug.