Bug 1087386 - Add support for wowlan in /etc/sysconfig/network-scripts/ifup-wireless
Summary: Add support for wowlan in /etc/sysconfig/network-scripts/ifup-wireless
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.6
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On:
Blocks: 1139649
TreeView+ depends on / blocked
 
Reported: 2014-04-14 09:49 UTC by Eduardo Minguez
Modified: 2016-11-25 13:01 UTC (History)
2 users (show)

Fixed In Version: initscripts-9.03.43-1.el6
Doc Type: Bug Fix
Doc Text:
Add possibility to enable wowlan in the ifup-wireless script.
Clone Of:
: 1139649 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:28:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
simple network-function patch (394 bytes, patch)
2014-04-14 09:50 UTC, Eduardo Minguez
no flags Details | Diff
simple ifup-wireless patch (789 bytes, patch)
2014-04-14 09:50 UTC, Eduardo Minguez
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1448 0 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2014-10-14 01:05:44 UTC

Description Eduardo Minguez 2014-04-14 09:49:53 UTC
Description of problem:
To enable wowlan support, iw command should be executed on every startup, but we should support an easy way to enable wowlan in the ifup-wireless script.

Version-Release number of selected component (if applicable):
initscripts-9.03.40-2.el6.i686

How reproducible:
Try to enable wowlan in an easy way without using rc.local

Steps to Reproduce:
1. 
2.
3.

Actual results:
You can create an initscript, crontab @reboot,... but it should be easier.

Expected results:
Not an easy way

Additional info:

Comment 1 Eduardo Minguez 2014-04-14 09:50:25 UTC
Created attachment 886077 [details]
simple network-function patch

Comment 2 Eduardo Minguez 2014-04-14 09:50:49 UTC
Created attachment 886078 [details]
simple ifup-wireless patch

Comment 4 Lukáš Nykrýn 2014-04-14 12:36:14 UTC
Thanks for the patch.

Comment 12 errata-xmlrpc 2014-10-14 06:28:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1448.html


Note You need to log in before you can comment on or make changes to this bug.