Bug 10874 - new LDAP code -- just why?!
new LDAP code -- just why?!
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: autofs (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-17 13:54 EDT by Michael Tokarev
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 14:47:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Tokarev 2000-04-17 13:54:02 EDT
from changelog for 3.1.4-7
* Tue Apr 11 2000 Nalin Dahyabhai <nalin@redhat.com>
- add LDAP map support, requires openldap

Huh, does the automount maps are in /etc/nsswitch.conf?
I don't know if autofs can use this, but for now (from 3.1.4-7),
but I can't use autofs package anymore since it requires ldap support...

Seemed to me like a development to the wrong direction...
Comment 1 Nalin Dahyabhai 2000-04-17 14:47:59 EDT
The autofs daemon has never consulted nsswitch.conf for automount information.
The crux of the problem is that the new lookup_ldap.so module in /usr/lib/autofs
requires the library, so even if you're not using LDAP maps (which are very
useful if you're migrating from NIS to LDAP), the package claims to require it.

I'll split the LDAP lookup module into a subpackage, but until it hits Raw Hide,
you can install the existing package with "--nodeps" to ignore the message.  The
operation of autofs won't be affected either way unless you are using LDAP maps.

Note You need to log in before you can comment on or make changes to this bug.