Bug 1087604 - grass bundles shapelib
grass bundles shapelib
Status: NEW
Product: Fedora
Classification: Fedora
Component: grass (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Devrim GÜNDÜZ
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2014-04-14 15:04 EDT by Ville Skyttä
Modified: 2016-12-28 18:19 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 07:22:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2014-04-14 15:04:50 EDT
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries
https://fedoraproject.org/wiki/Packaging:Treatment_Of_Bundled_Libraries

grass is using a bundled copy of shapelib.

$ repoquery --repoid=rawhide-debuginfo -l grass-debuginfo | grep shapelib
/usr/src/debug/grass-6.4.3/lib/external/shapelib
/usr/src/debug/grass-6.4.3/lib/external/shapelib/dbfopen.c
/usr/src/debug/grass-6.4.3/lib/external/shapelib/safileio.c
/usr/src/debug/grass-6.4.3/lib/external/shapelib/shapefil.h
/usr/src/debug/grass-6.4.3/lib/external/shapelib/shpopen.c
Comment 1 markusN 2014-04-14 15:15:35 EDT
This copy is a modified copy (see comments in
grass64/lib/external/shapelib/README)

To get the more recent original:

svn co http://svn.osgeo.org/gdal/branches/1.10/gdal/ogr/ogrsf_frmts/shape

It should be checked if a newer version of the library 
would still work in GRASS GIS.

Perhaps worth an upstream ticket at http://trac.osgeo.org/grass/
Comment 2 Ville Skyttä 2014-04-14 15:45:08 EDT
(In reply to markusN from comment #1)
> This copy is a modified copy (see comments in
> grass64/lib/external/shapelib/README)

Yes, I've read that. There's a process for cases where the system lib cannot be used (if this is indeed such a one), see the first link I posted, in particular:

https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#Exceptions
https://fedoraproject.org/wiki/Packaging:No_Bundled_Libraries#Requirement_if_you_bundle
Comment 3 markusN 2014-04-17 03:16:09 EDT
(In reply to markusN from comment #1)
> It should be checked if a newer version of the library 
> would still work in GRASS GIS.
> 
> Perhaps worth an upstream ticket at http://trac.osgeo.org/grass/

Found a related comment:

https://trac.osgeo.org/grass/ticket/1318#comment:2
Comment 4 Jaroslav Reznik 2015-03-03 10:42:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22
Comment 5 Fedora End Of Life 2016-07-19 07:22:10 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 6 Jan Kurik 2016-07-26 00:13:10 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.
Comment 7 markusN 2016-12-28 16:49:42 EST
A new SHAPELIB release is available after many years:
http://lists.maptools.org/pipermail/shapelib/2016-December/000631.html

It contains fixes from the older clone in GRASS GIS, so the new release is paving the way to get rid of this included copy. We'll try to get that done upstream in GRASS GIS, see

https://trac.osgeo.org/grass/ticket/3079#comment:6
Comment 8 Volker Fröhlich 2016-12-28 18:19:58 EST
Thank you very much for the news! For reference, shapelib 1.4.0 is only available in Rawhide at the moment.

Note You need to log in before you can comment on or make changes to this bug.