Bug 108771 - Unresolved symbol when loading module
Summary: Unresolved symbol when loading module
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-01 18:02 UTC by Tomas Edwardsson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-18 08:48:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tomas Edwardsson 2003-11-01 18:02:15 UTC
Couldn't find mod_dav_svn component in bugzilla so I'm just posting
this here.

Description of problem:
Unresolved symbols when loading the mod_dav_svn

Syntax error on line 2 of /etc/httpd/conf.d/subversion.conf:
Cannot load /etc/httpd/modules/mod_dav_svn.so into server:
/etc/httpd/modules/mod_dav_svn.so: undefined symbol: dav_xml_get_cdata



Version-Release number of selected component (if applicable):
mod_dav_svn-0.32.1-1
httpd-2.0.47-10
subversion-0.32.1-1

How reproducible:
Always

Steps to Reproduce:
1. Install mod_dav_svn RPM
2. Start httpd (service httpd start)

Comment 1 Tomas Edwardsson 2004-03-06 12:24:05 UTC
This is still a problem in FC t1.

Comment 2 Joe Orton 2004-04-18 08:48:53 UTC
There is a bug because:

Include conf.d/*.conf 

needs to be moved *after* the LoadModule lines in httpd.conf; in that
case, this works fine.  (mod_dav_svn must be loaded after mod_dav)

Comment 3 G. Roderick Singleton 2005-09-11 14:24:32 UTC
This bug should be reopened and the bug still exists in FC4. Requiring users to
re-configure in this manner is not productive.


Comment 4 G. Roderick Singleton 2005-09-11 14:25:09 UTC
.

Comment 5 G. Roderick Singleton 2005-09-11 15:15:50 UTC
Nevermind. I was too quick in checking /etc/httpd/conf/httpd.conf.rpmnew for the
change. It is there. My bad.


Note You need to log in before you can comment on or make changes to this bug.