Bug 1087786 - deploying configuration file scheduled by API: Failed deployment, rolled back: 'str' object has no attribute 'value'
deploying configuration file scheduled by API: Failed deployment, rolled back...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
2.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-15 06:11 EDT by Jan Hutař
Modified: 2017-10-27 11:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-27 11:26:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2014-04-15 06:11:38 EDT
Description of problem:
When you schedule deployment of an configuration file via API and then use rhn_check to perform the action, you will get: Failed deployment, rolled back:  'str' object has no attribute 'value'


Version-Release number of selected component (if applicable):
rhncfg-5.10.66-1.el5


How reproducible:
always


Steps to Reproduce:
1. Subscribe system into a config channel with one config file
2. Using API schedule the deployment
   >> configchannel.deployAllSystems(self.key, channelLabel)
3. On a client pick-up the action
   # rhn_check -vv


Actual results:
D: check_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>conf_chann_1_bz804782_tue15apr2014_05_46_33_15861</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>14abe0ac2fb2351d318fc72ab64bb367</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>{</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>SW5pdCAgQ29udGVudCAx\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>400</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/tmp/conf_chann_1_bz804782_tue15apr2014_05_46_33_15861-config_file.cfg</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string></string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>1</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 2251}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: rpcServer: Calling XMLRPC up2date.login
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at 1397555330.09 with expiration of 1397558930.09 seconds.
successfully retrieved authentication token from up2date server
D: logininfo:{'X-RHN-Server-Id': 1000010375, 'X-RHN-Auth-Server-Time': '1397555330.09', 'X-RHN-Auth': '0RIwAkRwftnJcB4Mucyxf6pj6TI/od7mPADXT41mh3g=', 'X-RHN-Auth-Channels': [['bz804782-25148', '20140415054714', '1', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>conf_chann_1_bz804782_tue15apr2014_05_46_33_15861</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>14abe0ac2fb2351d318fc72ab64bb367</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>{</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>SW5pdCAgQ29udGVudCAx\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>400</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/tmp/conf_chann_1_bz804782_tue15apr2014_05_46_33_15861-config_file.cfg</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string></string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>1</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 2251}
D: handle_action actionid = 2251, version = 2
D: do_call configfiles.deploy({'files': [{'config_channel': 'conf_chann_1_bz804782_tue15apr2014_05_46_33_15861', 'username': 'root', 'encoding': 'base64', 'checksum': '14abe0ac2fb2351d318fc72ab64bb367', 'filetype': 'file', 'delim_start': '|', 'modified': '', 'symlink': '', 'groupname': 'root', 'delim_end': '{', 'selinux_ctx': '', 'filemode': 400, 'file_contents': 'SW5pdCAgQ29udGVudCAx\n', 'checksum_type': 'md5', 'path': '/tmp/conf_chann_1_bz804782_tue15apr2014_05_46_33_15861-config_file.cfg', 'revision': 1}]},){'cache_only': None}
'str' object has no attribute 'value'
D: Sending back response(49, "Failed deployment, rolled back:  'str' object has no attribute 'value'", {})
D: do_call packages.checkNeedUpdate('rhnsd=1',){}
Loaded plugins: rhnplugin
D: rpcServer: Calling XMLRPC up2date.listChannels
This system is receiving updates from RHN Classic or Red Hat Satellite.
D: local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: rpcServer: Calling XMLRPC registration.welcome_message


Expected results:
Should work


Additional info:
When I have inserted:

            print "jhutar>>>>>"
            import traceback
            traceback.print_exc()
            print "jhutar<<<<<"

into /usr/share/rhn/actions/configfiles.py on line 306, I got this traceback:

[...]
D: do_call configfiles.deploy({'files': [{'config_channel': 'conf_chann_1_bz804782_tue15apr2014_05_46_33_15861', 'username': 'root', 'encoding': 'base64', 'checksum': '14abe0ac2fb2351d318fc72ab64bb367', 'filetype': 'file', 'delim_start': '|', 'modified': '', 'symlink': '', 'groupname': 'root', 'delim_end': '{', 'selinux_ctx': '', 'filemode': 400, 'file_contents': 'SW5pdCAgQ29udGVudCAx\n', 'checksum_type': 'md5', 'path': '/tmp/conf_chann_1_bz804782_tue15apr2014_05_46_33_15861-config_file.cfg', 'revision': 1}]},){'cache_only': None}
'str' object has no attribute 'value'
jhutar>>>>>
Traceback (most recent call last):
  File "/usr/share/rhn/actions/configfiles.py", line 218, in deploy
    dep_trans.deploy()
  File "/usr/share/rhn/config_common/transactions.py", line 359, in deploy
    self.newtemp_by_path[path], temp_new_dirs = fp.process(dep_file, os.path.sep)
  File "/usr/share/rhn/config_common/file_utils.py", line 97, in process
    modified = xmlrpc_time(file_struct['modified'].value)
AttributeError: 'str' object has no attribute 'value'
jhutar<<<<<
D: Sending back response(49, "Failed deployment, rolled back:  'str' object has no attribute 'value'", {})
[...]


This is not an issue on Satellite 5.6.0.
Comment 1 Rene Jr Purcell 2014-04-23 13:34:23 EDT
I confirm the issue, I get the same result. I'm trying to push a file "/etc/aaa/" containing only "xfgxgxgf".

Deployment is scheduled on the web interface, this is the result:
Summary:	Deploy config files to system scheduled by arsenick
Details:	This action will be executed after 04/23/14 1:12:00 PM EDT.

This action's status is: Failed.
The client picked up this action on 04/23/14 1:30:48 PM EDT.
The client completed this action on 04/23/14 1:30:48 PM EDT.
Client execution returned "Failed deployment, rolled back: 'str' object has no attribute 'value'" (code 49)
Config Files:
/etc/aaa (rev. 1)	
Time:	04/23/14 1:12:34 PM EDT

Output of rhn_check:

[root@localhost ~]# rhn_check -vv
D: opening  db environment /var/lib/rpm cdb:mpool:joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: added key gpg-pubkey-0608b895-4bd22942 to keyring
D: added key gpg-pubkey-863a853d-4f55f54d to keyring
D: added key gpg-pubkey-b3892132-4c63febc to keyring
D: added key gpg-pubkey-c105b9de-4e0fd3a3 to keyring
D: Using legacy gpg-pubkey(s) from rpmdb
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: check_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>base-sepaq</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>264addb5a3a91741d88329ce8807987d</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>{|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>|}</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>eGZneGd4Z2Y=\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>644</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/etc/aaa</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string></string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>1</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 102}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: rpcServer: Calling XMLRPC up2date.login
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at 1398274252.45 with expiration of 1398277852.45 seconds.
successfully retrieved authentication token from up2date server
D: logininfo:{'X-RHN-Server-Id': 1000010006, 'X-RHN-Auth-Server-Time': '1398274248.78', 'X-RHN-Auth': 'wuLfo52+IwnqX3HuSdP1WQ==', 'X-RHN-Auth-Channels': [['prod-centos6-x86_64', '20140324072756', '1', '1'], ['prod-epel_rhel6_x86_64', '20140413154109', '0', '1'], ['prod-spacewalk-client-2.1-centos6-x86_64', '20140414235043', '0', '1'], ['prod-rhel6-vm-x64-esx5-5', '20140416225329', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>base-sepaq</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>264addb5a3a91741d88329ce8807987d</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>{|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>|}</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>eGZneGd4Z2Y=\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>644</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/etc/aaa</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string></string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>1</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 102}
D: handle_action actionid = 102, version = 2
D: do_call configfiles.deploy({'files': [{'config_channel': 'base-sepaq', 'username': 'root', 'encoding': 'base64', 'checksum': '264addb5a3a91741d88329ce8807987d', 'filetype': 'file', 'delim_start': '{|', 'modified': '', 'symlink': '', 'groupname': 'root', 'delim_end': '|}', 'selinux_ctx': '', 'filemode': 644, 'file_contents': 'eGZneGd4Z2Y=\n', 'checksum_type': 'md5', 'path': '/etc/aaa', 'revision': 1}]},){'cache_only': None}
'str' object has no attribute 'value'
D: Sending back response(49, "Failed deployment, rolled back:  'str' object has no attribute 'value'", {})
D: do_call packages.checkNeedUpdate('rhnsd=1',){}
D: opening  db environment /var/lib/rpm cdb:mpool:joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: added key gpg-pubkey-0608b895-4bd22942 to keyring
D: added key gpg-pubkey-863a853d-4f55f54d to keyring
D: added key gpg-pubkey-b3892132-4c63febc to keyring
D: added key gpg-pubkey-c105b9de-4e0fd3a3 to keyring
D: Using legacy gpg-pubkey(s) from rpmdb
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm
Loaded plugins: fastestmirror, rhnplugin
Config time: 0.034
D: rpcServer: Calling XMLRPC up2date.listChannels
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Package Sacks
Loading mirror speeds from cached hostfile
 * base: less.cogeco.net
 * extras: centos.bhs.mirrors.ovh.net
 * updates: less.cogeco.net
pkgsack time: 0.121
rpmdb time: 0.000
Checking for new repos for mirrors
repo time: 0.001
D: local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: rpcServer: Calling XMLRPC registration.welcome_message
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm
Comment 2 Rene Jr Purcell 2014-04-23 13:48:23 EDT
I just saw the version number in the bug report is 2.2, I'm using 2.1 and I get the same result.

#rpm -qa |grep spacewalk
spacewalk-utils-2.1.27-1.el6.noarch
spacewalk-pxt-2.1.60-1.el6.noarch
spacewalk-java-postgresql-2.1.164-1.el6.noarch
spacewalk-java-lib-2.1.164-1.el6.noarch
spacewalk-backend-xmlrpc-2.1.55-1.el6.noarch
spacewalk-selinux-2.0.1-1.el6.noarch
spacewalk-monitoring-selinux-2.0.1-1.el6.noarch
spacewalk-setup-jabberd-2.0.1-1.el6.noarch
spacewalk-backend-xml-export-libs-2.1.55-1.el6.noarch
spacewalk-backend-iss-2.1.55-1.el6.noarch
spacewalk-backend-tools-2.1.55-1.el6.noarch
spacewalk-common-2.0.1-1.el6.noarch
rhn-org-httpd-ssl-key-pair-spacewalk.intra-1.0-1.noarch
spacewalk-admin-2.1.2-1.el6.noarch
spacewalk-repo-2.1-2.el6.noarch
spacewalk-doc-indexes-2.1.2-1.el6.noarch
spacewalk-backend-sql-postgresql-2.1.55-1.el6.noarch
spacewalk-backend-config-files-tool-2.1.55-1.el6.noarch
spacewalk-java-2.1.164-1.el6.noarch
spacewalk-backend-libs-2.1.55-1.el6.noarch
spacewalk-jpp-workaround-2.1.2-1.el6.noarch
spacewalk-sniglets-2.1.60-1.el6.noarch
spacewalk-branding-2.1.33-1.el6.noarch
spacewalk-search-2.1.14-1.el6.noarch
spacewalk-certs-tools-2.1.6-1.el6.noarch
spacewalk-backend-sql-2.1.55-1.el6.noarch
spacewalk-backend-app-2.1.55-1.el6.noarch
spacewalk-backend-iss-export-2.1.55-1.el6.noarch
spacewalk-backend-package-push-server-2.1.55-1.el6.noarch
spacewalk-setup-2.1.14-1.el6.noarch
spacewalk-taskomatic-2.1.164-1.el6.noarch
spacewalk-grail-2.1.60-1.el6.noarch
spacewalk-html-2.1.60-1.el6.noarch
spacewalk-setup-postgresql-2.1.4-1.el6.noarch
spacewalk-backend-server-2.1.55-1.el6.noarch
spacewalk-base-minimal-config-2.1.60-1.el6.noarch
spacewalk-backend-2.1.55-1.el6.noarch
spacewalk-base-2.1.60-1.el6.noarch
spacewalk-slf4j-1.6.1-5.el6.noarch
spacewalk-base-minimal-2.1.60-1.el6.noarch
spacewalk-backend-config-files-2.1.55-1.el6.noarch
spacewalk-config-2.1.5-1.el6.noarch
spacewalk-monitoring-2.0.1-1.el6.noarch
spacewalk-backend-config-files-common-2.1.55-1.el6.noarch
spacewalk-java-config-2.1.164-1.el6.noarch
spacewalk-backend-applet-2.1.55-1.el6.noarch
spacewalk-schema-2.1.51-1.el6.noarch
spacewalk-postgresql-2.0.1-1.el6.noarch
Comment 3 Jan Hutař 2014-04-25 05:46:45 EDT
Looks like this was already fixed at 2014-04-22 in SWnightly?
Comment 5 Rene Jr Purcell 2014-04-25 11:28:16 EDT
(In reply to Jan Hutař from comment #3)
> Looks like this was already fixed at 2014-04-22 in SWnightly?

I just updated to nightly build and I have get the same result trying to publish a config file, plus I'm unable to go to the event tab when i'm in the detail of a system, it redirect me to the default landing page (overview, https://spacewalk.intra.sepaq.com/rhn/YourRhn.do) but this is a different problem..

Update steps:
# yum --enablerepo=spacewalk-nightly update
# spacewalk-schema-upgrade

Installed packages after update:
[root@spacewalk ~]# rpm -qa |grep spacewalk
spacewalk-branding-2.2.1-1.el6.noarch
spacewalk-java-lib-2.2.53-1.el6.noarch
spacewalk-admin-2.2.1-1.el6.noarch
spacewalk-selinux-2.0.1-1.el6.noarch
spacewalk-backend-server-2.2.22-1.el6.noarch
spacewalk-backend-config-files-2.2.22-1.el6.noarch
spacewalk-setup-2.2.7-1.el6.noarch
spacewalk-java-2.2.53-1.el6.noarch
spacewalk-utils-2.2.12-1.el6.noarch
spacewalk-monitoring-selinux-2.0.1-1.el6.noarch
spacewalk-setup-jabberd-2.0.1-1.el6.noarch
rhn-org-httpd-ssl-key-pair-spacewalk.intra-1.0-1.noarch
spacewalk-backend-libs-2.2.22-1.el6.noarch
spacewalk-backend-app-2.2.22-1.el6.noarch
spacewalk-backend-iss-2.2.22-1.el6.noarch
spacewalk-base-2.2.15-1.el6.noarch
spacewalk-search-2.2.1-1.el6.noarch
spacewalk-setup-postgresql-2.2.1-1.el6.noarch
spacewalk-backend-sql-postgresql-2.2.22-1.el6.noarch
spacewalk-backend-config-files-common-2.2.22-1.el6.noarch
spacewalk-java-config-2.2.53-1.el6.noarch
spacewalk-backend-package-push-server-2.2.22-1.el6.noarch
spacewalk-base-minimal-config-2.2.15-1.el6.noarch
spacewalk-jpp-workaround-2.1.2-1.el6.noarch
spacewalk-backend-tools-2.2.22-1.el6.noarch
spacewalk-grail-2.2.15-1.el6.noarch
spacewalk-doc-indexes-2.2.1-1.el6.noarch
spacewalk-certs-tools-2.1.6-1.el6.noarch
spacewalk-base-minimal-2.2.15-1.el6.noarch
spacewalk-backend-xml-export-libs-2.2.22-1.el6.noarch
spacewalk-backend-iss-export-2.2.22-1.el6.noarch
spacewalk-sniglets-2.2.15-1.el6.noarch
spacewalk-taskomatic-2.2.53-1.el6.noarch
spacewalk-repo-2.2-1.el6.noarch
spacewalk-backend-2.2.22-1.el6.noarch
spacewalk-backend-xmlrpc-2.2.22-1.el6.noarch
spacewalk-backend-applet-2.2.22-1.el6.noarch
spacewalk-pxt-2.2.15-1.el6.noarch
spacewalk-common-2.2.1-1.el6.noarch
spacewalk-slf4j-1.6.1-6.el6.noarch
spacewalk-config-2.1.5-1.el6.noarch
spacewalk-backend-sql-2.2.22-1.el6.noarch
spacewalk-backend-config-files-tool-2.2.22-1.el6.noarch
spacewalk-html-2.2.15-1.el6.noarch
spacewalk-schema-2.2.25-1.el6.noarch
spacewalk-java-postgresql-2.2.53-1.el6.noarch
spacewalk-postgresql-2.2.1-1.el6.noarch
spacewalk-monitoring-2.0.1-1.el6.noarch


Result of rhn_check -vv:
# rhn_check -vv
D: opening  db environment /var/lib/rpm cdb:mpool:joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: added key gpg-pubkey-0608b895-4bd22942 to keyring
D: added key gpg-pubkey-863a853d-4f55f54d to keyring
D: added key gpg-pubkey-b3892132-4c63febc to keyring
D: added key gpg-pubkey-c105b9de-4e0fd3a3 to keyring
D: Using legacy gpg-pubkey(s) from rpmdb
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: check_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>base-sepaq</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>ec3c5c05a212c20ca690def7c2d3c79d</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>{|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>|}</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>I3hmZ3hneGdmCiNBQUFBQUFBQUFBQUFBQUFBQUEKI0JCQkJCQkJCQkJCQkJCQkJCQkJCQgojQ0ND\nQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDCiNEREREREREREREREREREREREREREREREREREQK\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>644</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/etc/aaa</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string>etc_t</string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>4</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 126}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: rpcServer: Calling XMLRPC up2date.login
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at 1398439576.61 with expiration of 1398443176.61 seconds.
successfully retrieved authentication token from up2date server
D: logininfo:{'X-RHN-Server-Id': 1000010006, 'X-RHN-Auth-Server-Time': '1398439576.41', 'X-RHN-Auth': 'M0X4upKQItLGbt4W6CMUjQ==', 'X-RHN-Auth-Channels': [['prod-centos6-x86_64', '20140324072756', '1', '1'], ['prod-epel_rhel6_x86_64', '20140413154109', '0', '1'], ['prod-spacewalk-client-2.1-centos6-x86_64', '20140414235043', '0', '1'], ['prod-rhel6-vm-x64-esx5-5', '20140416225329', '0', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>configfiles.deploy</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>files</name>\n<value><array><data>\n<value><struct>\n<member>\n<name>config_channel</name>\n<value><string>base-sepaq</string></value>\n</member>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>encoding</name>\n<value><string>base64</string></value>\n</member>\n<member>\n<name>checksum</name>\n<value><string>ec3c5c05a212c20ca690def7c2d3c79d</string></value>\n</member>\n<member>\n<name>filetype</name>\n<value><string>file</string></value>\n</member>\n<member>\n<name>delim_start</name>\n<value><string>{|</string></value>\n</member>\n<member>\n<name>delim_end</name>\n<value><string>|}</string></value>\n</member>\n<member>\n<name>symlink</name>\n<value><string></string></value>\n</member>\n<member>\n<name>modified</name>\n<value><string></string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>file_contents</name>\n<value><string>I3hmZ3hneGdmCiNBQUFBQUFBQUFBQUFBQUFBQUEKI0JCQkJCQkJCQkJCQkJCQkJCQkJCQgojQ0ND\nQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDCiNEREREREREREREREREREREREREREREREREREQK\n</string></value>\n</member>\n<member>\n<name>filemode</name>\n<value><int>644</int></value>\n</member>\n<member>\n<name>checksum_type</name>\n<value><string>md5</string></value>\n</member>\n<member>\n<name>path</name>\n<value><string>/etc/aaa</string></value>\n</member>\n<member>\n<name>selinux_ctx</name>\n<value><string>etc_t</string></value>\n</member>\n<member>\n<name>revision</name>\n<value><int>4</int></value>\n</member>\n</struct></value>\n</data></array></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 126}
D: handle_action actionid = 126, version = 2
D: do_call configfiles.deploy({'files': [{'config_channel': 'base-sepaq', 'username': 'root', 'encoding': 'base64', 'checksum': 'ec3c5c05a212c20ca690def7c2d3c79d', 'filetype': 'file', 'delim_start': '{|', 'modified': '', 'symlink': '', 'groupname': 'root', 'delim_end': '|}', 'selinux_ctx': 'etc_t', 'filemode': 644, 'file_contents': 'I3hmZ3hneGdmCiNBQUFBQUFBQUFBQUFBQUFBQUEKI0JCQkJCQkJCQkJCQkJCQkJCQkJCQgojQ0ND\nQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDQ0NDCiNEREREREREREREREREREREREREREREREREREQK\n', 'checksum_type': 'md5', 'path': '/etc/aaa', 'revision': 4}]},){'cache_only': None}
'str' object has no attribute 'value'
D: Sending back response(49, "Failed deployment, rolled back:  'str' object has no attribute 'value'", {})
D: do_call packages.checkNeedUpdate('rhnsd=1',){}
D: opening  db environment /var/lib/rpm cdb:mpool:joinenv
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: loading keyring from pubkeys in /var/lib/rpm/pubkeys/*.key
D: couldn't find any keys in /var/lib/rpm/pubkeys/*.key
D: loading keyring from rpmdb
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: added key gpg-pubkey-0608b895-4bd22942 to keyring
D: added key gpg-pubkey-863a853d-4f55f54d to keyring
D: added key gpg-pubkey-b3892132-4c63febc to keyring
D: added key gpg-pubkey-c105b9de-4e0fd3a3 to keyring
D: Using legacy gpg-pubkey(s) from rpmdb
D: opening  db index       /var/lib/rpm/Providename rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm
Loaded plugins: fastestmirror, rhnplugin
Config time: 0.033
D: rpcServer: Calling XMLRPC up2date.listChannels
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Package Sacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.rafal.ca
 * extras: centos.mirror.rafal.ca
 * updates: centos.mirror.rafal.ca
pkgsack time: 0.233
rpmdb time: 0.000
Checking for new repos for mirrors
repo time: 0.001
D: local action status: (0, 'rpm database not modified since last update (or package list recently updated)', {})
D: rpcServer: Calling XMLRPC registration.welcome_message
D: closed   db index       /var/lib/rpm/Providename
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm
Comment 6 Jan Hutař 2014-04-28 02:31:27 EDT
(In reply to Rene Jr Purcell from comment #5)
> (In reply to Jan Hutař from comment #3)
> > Looks like this was already fixed at 2014-04-22 in SWnightly?
> 
> I just updated to nightly build and I have get the same result trying to
> publish a config file, plus I'm unable to go to the event tab when i'm in
> the detail of a system, it redirect me to the default landing page
> (overview, https://spacewalk.intra.sepaq.com/rhn/YourRhn.do) but this is a
> different problem..
> 
> Update steps:
> # yum --enablerepo=spacewalk-nightly update
> # spacewalk-schema-upgrade

I do not comment on if the update steps are correct. I doubt updates in Nightly stream are supported. That might be the cause of your other issue (I'm unable to go to the event tab when i'm in the detail of a system).

Regarding initial issue: could you please check rhncfg version on your client (system to which you are deploying these config files) please?

# rpm -q rhncfg
Comment 7 Rene Jr Purcell 2014-04-28 08:01:33 EDT
Yeah sorry I have the bad habbit to give too many details..

Here's the version of rhncfg:

# rpm -q rhncfg
rhncfg-5.10.66-1.el6.noarch
Comment 8 Jan Hutař 2014-04-29 10:23:45 EDT
Sorry, I'm out of easy ideas. I have seen the issue with rhncfg-5.10.68-1.el6 and did not seen it with same one. So change have happened on Satellite side. Difference here is I'm testing against clean SWnightly installation. Not sure if it makes a difference.
Comment 9 Rene Jr Purcell 2014-05-01 09:38:08 EDT
(In reply to Jan Hutař from comment #8)
> Sorry, I'm out of easy ideas. I have seen the issue with
> rhncfg-5.10.68-1.el6 and did not seen it with same one. So change have
> happened on Satellite side. Difference here is I'm testing against clean
> SWnightly installation. Not sure if it makes a difference.

So it work on a clean SWnighly install right ? I can try to install a fresh one to confirm... Or do you know a timeframe where this code will go onto stable release ?
Comment 10 Jan Hutař 2014-05-06 08:38:37 EDT
(In reply to Rene Jr Purcell from comment #9)
> So it work on a clean SWnighly install right ? I can try to install a fresh
> one to confirm... Or do you know a timeframe where this code will go onto
> stable release ?

According to roadmap:

https://fedorahosted.org/spacewalk/roadmap

it looks like it will take 4 months get Spacewalk 2.2 released.
Comment 11 Jan Dobes 2017-10-27 11:26:59 EDT
This bug was apparently fixed by commit from this PR - https://github.com/spacewalkproject/spacewalk/pull/26/files. Closing this BZ.

Note You need to log in before you can comment on or make changes to this bug.