Bug 108781 - Evolution Summary page doesn't have right numbers for mailboxes.
Evolution Summary page doesn't have right numbers for mailboxes.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 17:59 EST by Ali-Reza Anghaie
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 08:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali-Reza Anghaie 2003-11-01 17:59:01 EST
Description of problem:

Evolution rarely has the right information on the Summary page for the
mailboxes. Right now it's showing 0/6 when I have 2 messages.
Yesterday it seemed to be taking a running total through the whole
day, 0/69 by the end when nothing was there. Etc.

Version-Release number of selected component (if applicable):

evolution-1.4.5-1

How reproducible:

Use Evolution for a few hours, checking the Summary page every so often.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2003-11-02 22:49:05 EST
What sorts of mail spools?  Quickly looking this seems fine to me, but
I'll grant that I don't have a large sample at the moment :)
Comment 2 Ali-Reza Anghaie 2003-11-02 23:53:23 EST
In this particular case it's POP3 off another server, so local
mbox-style folders for Evolution.

BTW, I'm not sure if it helps, but this seems to happen for ~all~ the
folders and just not Inbox. Any folder I add to the Summary page.. I
would think the type of spool wouldn't matter in that case because the
other folders are completely Evo stored... wait, that's not neccesary
true in the case of IMAP. In any case.  *scratches head*
Comment 3 Jeremy Katz 2003-11-03 00:02:53 EST
Hmm, all of mine are imap.  Might be related.  Will try to whip up
something to play with some remote pop as well.
Comment 4 Ali-Reza Anghaie 2003-11-03 00:28:19 EST
You might try to just create a few local folders and move things in,
delete them, out, mark them read/unread. You don't have to setup POP
to replicate this, I just did it without POP at all.... a bogus local
user w/ local mail did the same thing for me. Cheers, -Ali
Comment 5 Ali-Reza Anghaie 2003-11-05 14:52:13 EST
Ah ha! Something that might be useful.

I got home, 39 messages in my Inbox. Tons of spam I haven't trained on
yet. Well, I moved it to a training folder and wanted to train the
remaining of the Inbox as 'ham'. So I did that and it said it learned
39.... no no no.. Evo. doesn't show 39 in the inbox but the ~summary~
shows that and then some. It looks like the mbox file is ~not~
reflective of the Inbox in realtime. Make sense? Cat-ing the file
confirms it. Cheers, -Ali
Comment 6 Jeremy Katz 2003-11-05 14:55:11 EST
Hmm... perhaps.  If you expunge, does it reflect things?
Comment 7 Ali-Reza Anghaie 2003-11-05 15:03:55 EST
Yep, expunge does it.
Comment 8 Radek Vokal 2004-07-22 04:17:08 EDT
It happens all in Outbox - send message in offline mode, delete one
from outbox - Evolution is still trying to send previous number of
message! 
Comment 9 Ali-Reza Anghaie 2005-06-21 08:40:24 EDT
Closing this bug as newer Evo doesn't have the same structure to even have this
bug per se. Upgrade to RHEL 4. Cheers, -Ali
Comment 10 Dave Malcolm 2005-06-21 16:17:27 EDT
Thanks for the feedback.

Note You need to log in before you can comment on or make changes to this bug.