Bug 108782 - mesg now complains, /usr/bin/write broken?
mesg now complains, /usr/bin/write broken?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On: 110209
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-01 18:00 EST by Dax Kelson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 23:31:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dax Kelson 2003-11-01 18:00:21 EST
Description of problem:

I've noticed this for the past few months, but only tracked it down
today. I have a fully up2date fedora test3 box.

I have "/usr/bin/mesg y" in my .bash_profile. I've had this for years,
starting at some point with the Fedora betas, when I open a terminal
window within GNOME, I get this message:

mesg: error: tty device is not owned by group `tty'
[dkelson@mentor dkelson]$

The error message is true:

$ ls -al $(tty)
crw--w----    1 dkelson  dkelson  136,   7 Nov  1 15:58 /dev/pts/7

On a RHL9 box I get:

[dkelson@mooru dkelson]$ ls -al $(tty)
crw--w----    1 dkelson  tty      136,   0 Nov  1 16:00 /dev/pts/0

Since the "write" command is SGID tty, it is likely that it is broken.
I haven't tested it though.

Version-Release number of selected component (if applicable):
SysVinit-2.85-5
Comment 1 Bill Nottingham 2003-11-02 23:00:46 EST
Hm, perhaps gnome-pty-helper is behaving differently?
Comment 2 Dax Kelson 2003-11-19 23:31:23 EST
Fixed in initscripts-7.42.1-1.

Note You need to log in before you can comment on or make changes to this bug.