Bug 1088 - klogd doesn't like % in kernel messages
klogd doesn't like % in kernel messages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: sysklogd (Show other bugs)
1.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-09 10:02 EST by ink
Modified: 2017-01-23 13:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-09 13:15:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ink 1999-02-09 10:02:23 EST
In a recent 2.1-2.2 kernels messages like
"some_ide_controller: not 100% native mode: will probe irqs
later"
are quite common.
On some systems klogd segfaults on such messages, in the
best case klogd survives but corrupts these messages.
The reason is that printf and family count a single "%"
as a format operator, and expect an argument, which is
missing.
Debian folks fixed this problem some time ago, but their
way looks a bit complex for me, so I suggest another patch.


------- Email Received From  "Ivan N. Kokshaysky" <ink@jurassic.park.msu.ru> 02/09/99 10:06 -------
Comment 1 Jeff Johnson 1999-02-09 13:15:59 EST
Fixed in Raw Hide sysklogd-1.3-28.
Comment 2 openshift-github-bot 2017-01-23 13:52:00 EST
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/7f971336337ad19f87b8cae4586f589dfab3f294
Merge pull request #1164 from sg00dwin/icon-row-issue1088

Merged by openshift-bot

Note You need to log in before you can comment on or make changes to this bug.