Bug 1088003 - heartbeat interleaved with message frames causes decode error
Summary: heartbeat interleaved with message frames causes decode error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: 3.0
: ---
Assignee: Gordon Sim
QA Contact: Leonid Zhaldybin
URL:
Whiteboard:
Depends On:
Blocks: 1088004
TreeView+ depends on / blocked
 
Reported: 2014-04-15 19:51 UTC by Gordon Sim
Modified: 2019-02-15 13:39 UTC (History)
6 users (show)

Fixed In Version: python-qpid-0.22-14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1088004 (view as bug list)
Environment:
Last Closed: 2014-09-24 15:11:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
modification to broker to artificially make interleaving more likely (863 bytes, patch)
2014-05-12 14:33 UTC, Gordon Sim
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5700 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Gordon Sim 2014-04-15 19:51:43 UTC
Description of problem:

Heartbeat controls are sent on a separate 'track' from the message transfer command and accompanying header and content segments.

The OpDecoder is fed the segments as they occur, but does not account for the possibility of interleaving of assemblies on different tracks.

Version-Release number of selected component (if applicable):

Present in qpid 0.26

How reproducible:

Quite hard by normal means. In theory a python receiver with heartbeats set, getting a steady flow of messages over a long time would eventually hit this. For the purposes of testing fixes I introduced a sleep into the broker to artificially increase the chance of the interleaving.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gordon Sim 2014-04-15 19:52:29 UTC
Fix committed upstream: https://svn.apache.org/r1587710

Comment 4 Gordon Sim 2014-05-12 14:33:30 UTC
Created attachment 894739 [details]
modification to broker to artificially make interleaving more likely

Comment 5 Valiantsina Hubeika 2014-07-28 20:17:44 UTC
verified on
python-qpid-0.22-16

Comment 6 errata-xmlrpc 2014-09-24 15:11:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.