Bug 1088137 - Translation Editor: Alpha 1 Prototype
Summary: Translation Editor: Alpha 1 Prototype
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
: 3.6
Assignee: Luke Brooker
QA Contact: Zanata-QA Mailling List
URL: https://github.com/zanata/zanata-serv...
Whiteboard:
Keywords:
: 1110643 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-16 06:37 UTC by Michelle Kim
Modified: 2016-04-18 09:37 UTC (History)
4 users (show)

Fixed In Version: 3.6.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-2152)
Doc Type: Bug Fix
Doc Text:
Story Points: 8
Clone Of:
Environment:
Last Closed: 2015-03-19 07:10:23 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michelle Kim 2014-04-16 06:37:13 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Luke Brooker 2014-06-23 02:53:23 UTC
New Editor:

## Primary Goals

Bug free text editing
Distraction free
Fast text editing

## Secondary Goals

Easy and flexible TM use
Flexible search
Easy text customisation
Good keyboard shortcuts

## Tertiary Goals

Easy workspace customisation
Easy collaboration over comments

Comment 2 David Mason 2014-08-12 05:20:44 UTC
Required features as per https://bugzilla.redhat.com/show_bug.cgi?id=1110643

Comment 3 Michelle Kim 2014-08-12 05:24:21 UTC
*** Bug 1110643 has been marked as a duplicate of this bug. ***

Comment 4 Luke Brooker 2014-09-10 03:58:57 UTC
Progress can be tracked here: https://huboard.com/zanata/zanata-spa#/

Comment 5 Ding-Yi Chen 2014-10-14 00:22:28 UTC
https://github.com/zanata/zanata-server/pull/599

Comment 6 Ding-Yi Chen 2014-10-14 02:41:44 UTC
VERIFIED with Zanata 3.6.0-SNAPSHOT (git-jenkins-zanata-server-github-pull-requests-2152)


Note You need to log in before you can comment on or make changes to this bug.