Bug 108815 - Large copy with scp from openSSH fails
Large copy with scp from openSSH fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
i686 Linux
high Severity high
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 10:06 EST by Ernesto
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 09:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ernesto 2003-11-02 10:06:35 EST
Description of problem:
Transfer of large files such as 5.4 GB fails under openSSH
secure copy (i.e. scp)
The same result when trying to use ftp.

----- Error from scp -----------------------------------------
[williams@matrix ade]$ scp 192.168.1.102:ade/myADE.tgz
.williams@192.168.1.102's password:myADE.tgz                         
                                                     7%  438MB  
3.9MB/s   21:34 ETADisconnecting: Corrupted MAC on input.lost connection
--------------------------------------------------------------

Version-Release number of selected component (if applicable):
Linux matrix 2.4.22-1.2115.nptl #1 Wed Oct 29 15:42:51 EST 2003 i686
i686 i386 GNU/Linux

[root@matrix ssh]# rpm -q openssh
openssh-3.6.1p2-19


How reproducible:
Happens everytime

Steps to Reproduce:
1. Create a tar-gzipped file of size 5.4 GB on machine B
2. Attempt to copy via scp file from machine B
3.
  
Actual results:
Copy starts and fails after about 22% complete

Expected results:
Complete and successful transfer


Additional info:
Comment 1 Darren Tucker 2004-06-30 02:10:37 EDT
"Corrupted MAC on input" is usually the result of hardware (network or
host) problems.

There's also a well-documented firmware problem with LinkSys routers
that is known to cause this:
http://bugzilla.mindrot.org/show_bug.cgi?id=510
there's also a couple of other possibilities here:
http://bugzilla.mindrot.org/show_bug.cgi?id=845

FWIW I tried a 5.4GB scp to localhost on a FC2 box and it worked OK.

$ rpm -q fedora-release openssh
fedora-release-2-4
openssh-3.6.1p2-34
$ dd if=/dev/urandom of=/tmp/big bs=1024k count=5400
$ scp /tmp/big localhost:/tmp/big2
big                           100% 5400MB   7.4MB/s   12:07
$
Comment 2 Tomas Mraz 2005-02-07 09:28:07 EST
Works for me here as well.

Note You need to log in before you can comment on or make changes to this bug.