Bug 108818 - df -a returns segmentation fault
df -a returns segmentation fault
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: coreutils (Show other bugs)
9
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 10:43 EST by Thomas W Blanchard
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-10 11:44:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas W Blanchard 2003-11-02 10:43:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
When I try to find the amount of free disk space running df -a or df -l,
I get a Segmentation fault message. If I try to run KDiskFree, the
window opens then immediately closes. I need to determine how much
free space I have and I am not able to. I have Samba 3.0 and Apache
also running on the system. They both seem to work fine.

It happens whether I am logged in as root or telnetting into the
system. We also have other systems having the same issue. On systems
where the commands work, they do not have Samba and Apache running.
Could they be causing the issue, and if so, is there a way to fix it?

Version-Release number of selected component (if applicable):
rpm-4.2-0.69; kernel-2.4.20-20.9smp

How reproducible:
Always

Steps to Reproduce:
1.Open a terminal window
2.su to root if not logged in as root
3.run df -a or df -l to find free space
    

Actual Results:  I will always receive the segmentation fault when
running the command

Additional info:
Comment 1 Harald Hoyer 2003-11-03 04:39:04 EST
reassigning to correct component
Comment 2 Tim Waugh 2003-11-03 05:20:46 EST
Please do this:

gdb --args df -a
(gdb) run
...
(gdb) bt

and show me the output.

Also, does this happen when you are *not* root?
Comment 3 Thomas W Blanchard 2003-11-03 10:58:49 EST
This occurs whether or not I am logged in as root. I used my account
first and when I received the error, I tried root. 
When I run the gdb --args df -a then 'run' at the gdb>, it shows:
0x08049125 in strcpy().
When I run bt:
#0  0x08049125 in strcpy ()
#1  0x0804d623 in _IO_stdin_used ()
#2  0x00804aa0f in strcpy ()
#3  0x420156a4 in _libc_start_main () from /lib/tls/libc.so.6

Hope this helps. Let me know what other information you need. I am not
an expert in Linux, but trying to learn more about it. I do have 2
other computers running RedHat 9 and I am able to run the df -a
command as well as KDiskFree to determine how much free space I have.
One of the computers is also a dual processor system with an internal
RAID, just older.  It does not have Apache running but does have
Samba 3.0 running. 
Comment 4 Tim Waugh 2003-11-04 11:47:59 EST
You should have coreutils-4.5.3-19.0.2 installed, from the latest
updates with up2date.  If not, please let me know what version you do
have.

Please fetch and install this package:
ftp://people.redhat.com/twaugh/tmp/coreutils-debuginfo-4.5.3-19.0.2.i386.rpm

Then try 'gdb --args df -a' again -- you should get more information
in the output this time.  Thanks.
Comment 5 Thomas W Blanchard 2003-11-10 11:42:49 EST
You can close this now. After running the coreutils update, it fixed
the issue. i am now able to view free disk space using KDiskFree or df
-a. Thank you for your help.

Note You need to log in before you can comment on or make changes to this bug.