Bug 10883 - xfs fails to start up causing X itself to fail starting up
Summary: xfs fails to start up causing X itself to fail starting up
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-17 23:57 UTC by Charles R. Anderson
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-30 18:32:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles R. Anderson 2000-04-17 23:57:01 UTC
The X Font Server fails to start up when /etc/rc.d/init.d/xfs calls
mkfontdir due to mkfontdir making non-world-readable fonts.dir files.
This also causes the X server to fail starting up.  To fix this, insert a
umask command before mkfontdir is called in the init script:

...
buildfontlist() {
	umask 022
        for d in /usr/X11R6/lib/X11/fonts/* /usr/X11R6/lib/X11/fonts/*/*
/usr/share/fonts/* /usr/share/fonts/*/*; do
...

Comment 1 SB 2000-05-15 15:28:59 UTC
Is your system setup different than default, because I haven't
experienced this problem and I have setup two separate systems
with 6.2 and the permissions have been correct on both and xfs
has been starting up normal.  Did you upgrade or something?

-Stan Bubrouski

Comment 2 Charles R. Anderson 2000-05-15 15:36:59 UTC
Not that I know of.  Perhaps my default umask for root is different, but
I just now experienced the same problem on a brand new install on an
alpha.  It only seems to show up after the next reboot after running X.
(i.e., it did not happen the first time I started up X.)  After rebooting,
xfs reports "[ OK ]" on startup, but "ps auxw|grep xfs" shows that xfs is
not actually running.

Comment 3 Preston Brown 2000-05-30 18:32:59 UTC
have you changed your default root umask?

Comment 4 Preston Brown 2000-06-26 19:32:59 UTC
you have changed your default root umask, but I have adjusted the xfs init
script to check for this for our next release.


Note You need to log in before you can comment on or make changes to this bug.