This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 108852 - ECN precludes connecting to some broadband routers
ECN precludes connecting to some broadband routers
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 14:30 EST by Dan Berger
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-02 19:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Berger 2003-11-02 14:30:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; Galeon)
Gecko/20030701 Galeon/1.3.9

Description of problem:
I ran into this a few days ago - it's not really a bug in the kernel -
more of an interoperability problem, but since it's likely to affect a
non-trivial number of users, I figured it was worth reporting.

The 2.6 test kernels have TCP ECN enabled - and my dlink wireless
router (a DI-713P, to be precise) doesn't respond correctly to TCP
SYNs with ECN set - making it impossible to access the web
configuration interface from my machine.

disabling ecn 

# sysctl -w net.ipv4.tcp_ecn=0

allows access.


Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test9.1.67

How reproducible:
Always

Steps to Reproduce:
1. N/A
2.
3.
    

Additional info:
Comment 1 Dave Jones 2003-11-02 19:27:07 EST
Check if theres a firmware upgrade that fixes this problem.
if not, bug Dlink. It's their problem if they can't cooperate with
standardised internet RFCs.

I realise this isn't much help to you the end user, but the fact is,
d-link sold you a defective product. Luckily you can work around it in
the manner you describe above.
Comment 2 Dan Berger 2003-11-03 12:59:13 EST
I've already done all of the above (checked the latest firmware and
bugged dlink) - I filed this in bugzilla more to help others who might
run into the same issue and not instinctively turn to ethereal to
figure out what's going on.
Comment 3 Aleksey Nogin 2004-03-01 19:26:27 EST
Same here with a Linksys router.

Note You need to log in before you can comment on or make changes to this bug.