Bug 1088566 - fdupes: Double macros.d
Summary: fdupes: Double macros.d
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fdupes
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-16 18:37 UTC by Jerry James
Modified: 2014-05-02 16:00 UTC (History)
2 users (show)

Fixed In Version: fdupes-1.51-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-28 04:51:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Jerry James 2014-04-16 18:37:10 UTC
Description of problem:
In Rawhide and F-20, the fdupes RPM macro file is at:

/usr/lib/rpm/macros.d/macros.d/macros.fdupes

Notice that there are two "macros.d" elements in that path.

Version-Release number of selected component (if applicable):
fdupes-0:1.51-5.fc21.x86_64

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:
N/A

Expected results:
N/A

Additional info:

Comment 1 Björn 'besser82' Esser 2014-04-18 10:12:10 UTC
Hello Jerry!

Thanks for the bug-report!  I fixed the issue on all recently maintained releases of epel and fedora in this commit:  http://pkgs.fedoraproject.org/cgit/fdupes.git/commit/?id=57fdb45d92bc3dde36c97292bd2ce80179286bc4

Builds are currently running.

Cheers,
  Björn

Comment 2 Fedora Update System 2014-04-18 10:18:17 UTC
fdupes-1.51-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fdupes-1.51-6.el5

Comment 3 Fedora Update System 2014-04-18 10:18:38 UTC
fdupes-1.51-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fdupes-1.51-6.el6

Comment 4 Fedora Update System 2014-04-18 10:19:00 UTC
fdupes-1.51-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fdupes-1.51-6.fc19

Comment 5 Fedora Update System 2014-04-18 10:23:32 UTC
fdupes-1.51-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fdupes-1.51-6.fc20

Comment 6 Björn 'besser82' Esser 2014-04-18 10:25:44 UTC
tagged buildroot-overrides for affected releases with above submitted update

Comment 7 Fedora Update System 2014-04-19 09:18:05 UTC
Package fdupes-1.51-6.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fdupes-1.51-6.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1163/fdupes-1.51-6.el6
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-04-28 04:51:36 UTC
fdupes-1.51-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-04-28 04:52:33 UTC
fdupes-1.51-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-05-02 16:00:24 UTC
fdupes-1.51-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-05-02 16:00:43 UTC
fdupes-1.51-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.