Bug 1088916 - WS-I Basic Security Profile 1.1 support
Summary: WS-I Basic Security Profile 1.1 support
Keywords:
Status: VERIFIED
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services
Version: 6.2.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: EAP 6.4.0
Assignee: Jimmy Wilson
QA Contact: Rostislav Svoboda
Lucas Costi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-17 12:38 UTC by Rostislav Svoboda
Modified: 2018-12-07 22:33 UTC (History)
9 users (show)

Doc Type: Enhancement
Doc Text:
This release of JBoss EAP 6 now supports WS-I Basic Security Profile 1.1.
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Rostislav Svoboda 2014-04-17 12:38:18 UTC
https://issues.jboss.org/browse/EAP6-52
WSI BSP 1.1 functionality was verified.

Declare WSI-Basic Security Profile 1.1 support in documentation.

Comment 1 Jim Ma 2014-04-18 06:09:19 UTC
The compliance has been tested by Rosta against the EAP 6.3 release. We can declare this in the release notes.

Comment 2 Russell Dickenson 2014-05-04 22:48:58 UTC
In addition to declaring this in the Release Notes, I suggest the following document also be updated - https://access.redhat.com/site/articles/113373.

This BZ ticket is related to BZ1006638 - "Declare WS-I Basic Profile 2.0 support".

Comment 8 Rostislav Svoboda 2014-05-14 06:58:02 UTC
Verified in RN - "JBoss_Enterprise_Application_Platform-6.3.0_Release_Notes-6.3-en-US-6.3.0-4"

Moving to Jimmy for KB article update.

Comment 10 Rostislav Svoboda 2014-06-24 06:49:50 UTC
WS-I Basic Security Profile 1.1 was confirmed with EAP 6.3.0
There were changes needed in CXF codebase to pass it - so it's not covered in earlier versions - not even in EAP 6.2.0.

Foot note that 1.1 came with specific 6.3 would be good.

Comment 13 Dimitris Andreadis 2014-11-20 17:02:55 UTC
I think this is for Jimmy to do something?

Comment 16 Rostislav Svoboda 2015-02-24 09:11:50 UTC
Verified

WS-I Basic Security Profile 	1.1[1]
 [1] Certified starting with 6.3.0.


Note You need to log in before you can comment on or make changes to this bug.