Bug 108902 - cjk fonts are always seen AA in gnome-terminal 2.4.1
cjk fonts are always seen AA in gnome-terminal 2.4.1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-02 20:43 EST by sangu
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 00:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fonts is "Andale Mono" in this screenshot. (46.62 KB, image/png)
2004-10-01 00:32 EDT, sangu
no flags Details

  None (edit)
Description sangu 2003-11-02 20:43:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ko-KR; rv:1.5)
Gecko/20031016 Epiphany/1.0.4

Description of problem:
 Some cjk fonts(Gulim, Gulimche, MS Gothic and etc) are "AA OFF" in
~/.fonts.conf.

But the cjk fonts are seen AA in gnome-terminal.

the cjk fonts in the other gtk2 programs are seen "AA Off".

Version-Release number of selected component (if applicable):
 gnome-terminal 2.4.1

How reproducible:
Always

Steps to Reproduce:
1. Some cjk fonts AA OFF in ~/.fonts.conf
 <edit name="antialias" mode="assign"><bool>false</bool></edit>
2. select AA off cjk fonts in gnome-terminal.
3. seen AA CJK fonts in gnome-terminal. but seen AA Off CJK in the
others gtk2 programs.
    

Additional info:
Comment 1 Warren Togami 2004-04-13 23:57:42 EDT
i18n team, any comments about this?
Comment 2 Akira TAGOH 2004-05-17 03:33:04 EDT
It looks like it's vte fault. VTE_USE_XFT=0 gnome-terminal looks fine,
though.
Comment 3 Leon Ho 2004-10-01 00:10:01 EDT
Please try to use Gnome menu -> Preference -> Font. gnome-terminal
able to use non-AA for me on that.
Comment 4 sangu 2004-10-01 00:32:28 EDT
Created attachment 104614 [details]
fonts is "Andale Mono" in this screenshot.

vte-0.11.11-5, gnome-terminal-2.7.3

in ~/.fonts.conf

<fontconfig>
[...]
<match target="font" >
		<test qual="any" name="family">
			<string>Arial</string>
			<string>Verdana</string>
			<string>Tahoma</string>
			<string>Andale Mono</string>
		</test>
		<test compare="more" name="pixelsize" qual="any">
		<double>10</double>
		</test>
		<test compare="less" name="pixelsize" qual="any">
		<double>15</double>
		</test>
		<edit mode="assign" name="antialias" >
		<bool>false</bool>
		</edit>
</match>

<match target="pattern">
		<test name="family">
			<string>Andale Mono</string>
		</test>
		<edit name="family" mode="append" binding="strong">
			<string>GulimChe</string>
		</edit>
	</match>
[...]
</fontconfig>

This fontconfig setup file doesn't is applied to gnome-terminal, but the other
gtk2 programs work well.

Note You need to log in before you can comment on or make changes to this bug.