This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 108916 - Firewire regression: HDD failed to be detected using latest kernel
Firewire regression: HDD failed to be detected using latest kernel
Status: CLOSED DUPLICATE of bug 101227
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 00:53 EST by Michel Alexandre Salim
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2003-11-03 00:53:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031022 Firebird/0.7 StumbleUpon/1.89

Description of problem:
I use a Firewire external HDD that works fine under
2.4.22-1.2105.nptl; yesterday I installed -1.2115.nptl and upon
booting it kudzu reported that the Firewire drive no longer exists.

Note: I have to use the rescan-scsi-bus.sh script from linux1394 to
get the drive to work even under -1.2105.nptl

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2115.nptl

How reproducible:
Always

Steps to Reproduce:
1. Attach sbp2 HDD to a computer running -1.2105.nptl
2. Configure
3. Reboot to -1.2115.nptl
    

Actual Results:  Hard drive deconfigured

Expected Results:  Hard drive still usable

Additional info:

$ /sbin/lsmod|grep sbp
sbp2                   21004   1
ieee1394              204676   0 [sbp2 ohci1394]
scsi_mod              108168   3 [sd_mod sbp2 usb-storage]

I've perused the Changelogs for the two kernels and since Rd Hat
compiles using gcc32 anyway, presumably this results from either the
removal of the orlov patch, or the ACPI changes being backed out?

Funnily, even Apple seems to be having probs with Firewire these days...
Comment 1 Dave Jones 2003-11-10 12:07:29 EST
Another victim of the ongoing firewire problems..


*** This bug has been marked as a duplicate of 101227 ***
Comment 2 Michel Alexandre Salim 2003-11-24 00:44:37 EST
Turns out the problem is ACPI (yet again). My hard drive works (after
manually rescanning scsi devices) if I boot with acpi=on
(necessitating removing 'rhgb' as it locks up otherwise). Quite
interesting, it seems like without the 'acpi=on' option ACPI is
half-enabled on my notebook (Vaio Z1MP, Pentium-M 1.3)
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.