Bug 10896 - man pages contain @PREFIX@'s, gnats user setup wrong.
Summary: man pages contain @PREFIX@'s, gnats user setup wrong.
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: gnats   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-18 18:02 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-19 09:30:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-18 18:02:11 UTC
Rebuilt the SRPM on Redhat 6.0.


Some man pages contain @PREFIX@'s.  For instance gnats(7):

----
Administrative  programs  and  programs  internal  to  GNATS  are  kept
in  the   directory   @PRE-
       FIX@/libexec/gnats while those meant for public use are installed in
@PREFIX@/bin.

       @PREFIX@/libexec/gnats contains the programs:
---- (sorry for the mangled mess) ----

Also, gnats-user's setup in spec file is silly.  See:
----
    /usr/sbin/useradd -c "Gnats User" \
       -r -d /usr/share/gnats/gnats-db/gnats-adm/config gnats 2>/dev/null
|| :
    exit 1
----
/usr/share/gnats/gnats-db/gnats-adm/config is the configuration file.
Having this as a home directory is a little silly.

Also, an enhancement request:  On newer system's  - Redhat 6.2 specifically
- UID's used by system accounts have been set to be below 100.  Using this
scheme if possible when setting up the account for gnats would be neat,
too. :)

Comment 1 Tim Powers 2000-04-18 18:16:59 UTC
I think that the problem is more than likely stemming from the fact that gnats
was built with a newer version of RPM than 6.0 has, try upgrading RPM and
rebuilding the package, then you should be able to get rid of all the PREFIX
cruft you are seeing. I can't reproduce this problem here.

Also, concerning the uids, I couldn't agree more. This was an oversight and will
be fixed int eh next release of Powertools.

Tim

Comment 2 Pekka Savola 2000-04-19 09:30:59 UTC
Weird.  I upgraded my Redhat-6.1 workstation to rpm-3.0.4-7 (plus the
dependencies), rebuilt the package and *some* directories (not all, e.g.
/var/lib/gnats is fine) look @PREFIX@'ed still :(

Also, it seems my systems and gnats don't mix well:
----
[root@mybox /tmp]# rpm -e gnats
cannot remove /usr/share/gnats/gnats-db - directory not empty
[root@mybox /tmp]# rpm -Uvh /usr/src/redhat/RPMS/i386/gnats-3.113-5.i386.rpm
execution of script failed
[root@mybox /tmp]#  rpm -Uvh /usr/src/redhat/RPMS/i386/gnats-3.113-5.i386.rpm
gnats                       ##################################################
----
The first message is understandable (I didn't install gnats-db, because I will
build my own), but the second seemed tricky.

Also, some files in /usr/libexec/gnats should be setuid gnats.  Specfile seems
to be doing that (I see it chown gnats xxx; chmod 4755 xxx some files!) but
they're changed to setuid root now:

---
-r-sr-xr-x   1 root     root        51588 Apr 19 12:27 gen-index
-r-sr-xr-x   1 root     root        84808 Apr 19 12:27 pr-edit
-r-sr-xr-x   1 root     root        52932 Apr 19 12:27 queue-pr
---

Gnats user seems to have been added properly (/etc/passwd):
---
gnats:x:155:155:Gnats User:/usr/share/gnats/gnats-db/gnats-adm/config:/bin/bash
---

'rpm -V gnats' doesn't show anything (e.g. suid owner conflicts), so there I
fear there has been a glitch in the rebuilding.

Weird.  Any ideas?

Comment 3 Tim Powers 2000-11-07 16:54:22 UTC
I'm closing this since we aren't shipping/maintaining the gnats package anymore.
It appears to be a dead project as well.

Tim



Note You need to log in before you can comment on or make changes to this bug.