Bug 1089616 - [GSS] (6.2.x) High CPU usage by JMX monitoring client, RBAC seems the hotspot
Summary: [GSS] (6.2.x) High CPU usage by JMX monitoring client, RBAC seems the hotspot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: CR2
: EAP 6.2.3
Assignee: Osamu Nagano
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On: 1077536
Blocks: eap62-cp03-blockers
TreeView+ depends on / blocked
 
Reported: 2014-04-21 07:42 UTC by Osamu Nagano
Modified: 2018-12-05 18:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A performance issue affecting JMX Query was identified, where the CPU load was much higher than expected in previous JBoss EAP releases. The cause of the issue was that role-based access control (RBAC) was checking the address of every query, regardless of whether that address was relevant to JMX Query. To resolve this issue the processing of querie was changed to first check if the address is relevant to JMX Query and if not, avoid the processing involved. The result of this change is that CPU load of JMX monitoring is again at a normal level.
Clone Of: 1077536
Environment:
Last Closed: 2014-06-09 12:47:09 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker WFLY-3161 Major Resolved Optimize org.jboss.as.jmx.model.RootResourceIterator 2018-11-13 19:08:38 UTC

Comment 2 Petr Kremensky 2014-05-09 06:10:26 UTC
Verified on EAP 6.2.3.CR2.


Note You need to log in before you can comment on or make changes to this bug.