Bug 108962 - An X/Motif display applications colormap reverts from a private colormap to system default colormap when accessing any of the applications Menubars
An X/Motif display applications colormap reverts from a private colormap to s...
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-03 15:22 EST by Scott Carter
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Carter 2003-11-03 15:22:55 EST
Description of problem:
I have several custom X/Motif display applications which were 
developed and have been working perfectly under Solaris, IRIX, HP-UX 
and the Redhat Motif Window Manager. However under Redhats KDE the 
colormap reverts from a private colormap to system default colormap 
when accessing any of the applications Menubars.

The system is a new Dell 3.0Ghz Pentium with the highest power Quadra 
Nvidia board one can buy. I have loaded the latest Nvidia driver and 
relevent Redhat patches.

I have read Ids 65310, 65740 and 91217 and avoid the color allocation 
problem by allocating and installing an application specific 
colormap.  This is valid and well documented in the X/Motif manuals, 
and this works well under the above OSs / WMs except KDE. The system 
is set up for 8 bit Pseudo color since the applications required 
plane separation which 24bit TrueColor does not support. I have tried 
Nvidias 8 bit overlay with 24 bit normal configuration but the driver 
still seems not to support it and some documentation suggests the 
overlay will only be on the first monitor of a multi monitor system 
(NG). I have also tried both SLS (Single Logical Screen) and Dual 
Monitor configurations.

I have made numerous modifications to application to explicitly 
install the colormap into every menubar and its children. I have also 
explicitly advised the Window Manager as to the new colormap, still 
with no luck.

Since the application works fine under Redhats Mwm, the Motif Window 
Manager, I have to to suspect KDE.

Do you have any ideas which might fixed this?



Version-Release number of selected component (if applicable):


How reproducible:
Every run.

Steps to Reproduce:
1.Run program
2.Select any menubar item - colormap reverts to standard
3.Select any area or any other button - colormap reverts to 
applications map.
  
Actual results:
Colormap reverts to KDE standard map when selectin menubar.

Expected results:
Colormap should remain fixed at installed private map.

Additional info:
Comment 1 Petr Rockai 2006-07-17 14:40:03 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 2 Bill Nottingham 2006-10-18 14:16:17 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.