Bug 1089835 - [GSS] (6.3.0) ClientConsumer max rate not taking effect if ServerLocator's consumerMaxRate <=0
Summary: [GSS] (6.3.0) ClientConsumer max rate not taking effect if ServerLocator's co...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Clebert Suconic
QA Contact: Miroslav Novak
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1064596 1084639 1088599
TreeView+ depends on / blocked
 
Reported: 2014-04-22 04:30 UTC by Jimmy Wilson
Modified: 2014-08-06 14:35 UTC (History)
4 users (show)

(edit)
In previosus versions of JBoss EAP 6, the Core API method `createConsumer(String queueName, String filter, int windowSize, int maxRate, boolean browseOnly)` ignored the parameter `maxRate` if the `ConnectionFactory` (or `ServerLocator`) had set `maxRate` to its default value of less than or equal to zero.

The root cause of this issue was faulty logic in the `createConsumer` method. It has been corrected in this release.
Clone Of: 1088599
(edit)
Last Closed: 2014-08-06 14:35:08 UTC


Attachments (Terms of Use)

Description Jimmy Wilson 2014-04-22 04:30:00 UTC
+++ This bug was initially created as a clone of Bug #1088599 +++

If ServerLocator's consumerMaxRate is <= 0 (the default), specifying maxRate with ClientSession.createConsumer() methods that take it makes no difference, maxRate ends up being ignored.

Comment 1 Russell Dickenson 2014-05-13 23:19:56 UTC
I have completed the Release Notes entry for this BZ ticket, based on RN text from BZ1088599.

Comment 2 Kabir Khan 2014-07-01 14:26:30 UTC
Should be fixed by upgrade https://bugzilla.redhat.com/show_bug.cgi?id=1064596 for DR2

Comment 3 Miroslav Novak 2014-07-02 07:38:13 UTC
Verified in EAP 6.3.0.ER7 using provided tests MessageRateTest.


Note You need to log in before you can comment on or make changes to this bug.