Bug 1089842 - [GSS] (6.3.0) listMessagesAsJSON method fails to list messages if the filter property contians \n character.
Summary: [GSS] (6.3.0) listMessagesAsJSON method fails to list messages if the filter ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Clebert Suconic
QA Contact: Miroslav Novak
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1064596 1084639 1088602
TreeView+ depends on / blocked
 
Reported: 2014-04-22 04:40 UTC by Jimmy Wilson
Modified: 2014-08-06 14:37 UTC (History)
4 users (show)

(edit)
In previous versions of JBoss EAP 6, filter parsing failed to parse messages correctly if the message contained a new line character (`\n`) inside a string or any other property.

The root cause of this issue was faulty logic in the `listMessagesAsJSON` method, which failed to account for a newline character.

This issue has been resolved in this release.
Clone Of: 1088602
(edit)
Last Closed: 2014-08-06 14:37:51 UTC


Attachments (Terms of Use)

Description Jimmy Wilson 2014-04-22 04:40:14 UTC
+++ This bug was initially created as a clone of Bug #1088602 +++

listMessagesAsJSON fails to list messages if filter property coanitns '\n' character.

For example filter '%1234%' will list messages containing 'hello1234' but it will not list the same message if the string is 'hello1234\n'.

Comment 1 Russell Dickenson 2014-05-14 03:42:38 UTC
'Known Issue' text added for the Beta release. The following text can be used for the final release.

"Filter parsing failed to parse messages correctly if the they contained a new line character (`\n`) inside a string or any other property. The root cause of this issue was faulty logic in the `listMessagesAsJSON` method, which failed to account for a newline character. This issue has now been resolved by improving the handling of messages in method `listMessagesAsJSON`. As a result, messages are correctly parsed, even when containing one or more new line characters."

Comment 2 Kabir Khan 2014-07-01 14:27:10 UTC
Should be fixed by upgrade https://bugzilla.redhat.com/show_bug.cgi?id=1064596 for DR2

Comment 3 Miroslav Novak 2014-07-02 08:17:58 UTC
Verified using FilterTest in EAP 6.3.0.ER7. Thanks


Note You need to log in before you can comment on or make changes to this bug.