Bug 1089843 - [GSS] (6.3.0) Spurious WARN messages after XmlDataImporter deletes temp file
Summary: [GSS] (6.3.0) Spurious WARN messages after XmlDataImporter deletes temp file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ
Version: 6.2.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR2
: EAP 6.3.0
Assignee: Clebert Suconic
QA Contact: Miroslav Novak
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1064596 1084639 1088603
TreeView+ depends on / blocked
 
Reported: 2014-04-22 04:42 UTC by Jimmy Wilson
Modified: 2014-08-06 14:35 UTC (History)
4 users (show)

(edit)
In previous versions of JBoss EAP 6, when the `XmlDataImporter` was importing large messages, spurious 'WARN' messages were logged.

The root cause of this issue was that when importing sufficiently large messages, the `XmlDataImporter` created a temporary file and deleted it when the import task was complete.

When importing another large message, the `XmlDataImporter` function tried to delete the temporary file again and, since the file was no longer present, logged the WARN message. 

This issue has been resolved in this release.
Clone Of: 1088603
(edit)
Last Closed: 2014-08-06 14:35:20 UTC


Attachments (Terms of Use)

Description Jimmy Wilson 2014-04-22 04:42:04 UTC
+++ This bug was initially created as a clone of Bug #1088603 +++

When the XmlDataImporter generates and subsequently deletes a temp file (e.g. for a large message) it will continue trying to delete that same file whenever it imports another message and log spurious WARN messages when it can't.

Comment 1 Russell Dickenson 2014-05-14 04:46:59 UTC
I have written a RN entry for the 'Known Issues' section as the fix is not included in ER3. For the product's final release, the following RN text can be published:

"When the `XmlDataImporter` was importing large messages, spurious 'WARN' messages were logged. The root cause of this issue was that when importing sufficiently large messages, the `XmlDataImporter` created a temporary file and deleted it when the import task was complete. When importing another large message, the `XmlDataImporter` function tried to delete the temporary file, which no longer existed, and so logged the WARN message. The handling of temporary files in the `XmlDataImporter` function has now been modified and as a result, spurious WARN messages are no longer logged."

Comment 2 Kabir Khan 2014-07-01 14:27:38 UTC
Should be fixed by upgrade https://bugzilla.redhat.com/show_bug.cgi?id=1064596 for DR2

Comment 3 Miroslav Novak 2014-07-02 08:28:35 UTC
Already verified for EAP 6.2.3.CR2 where code of XmlDataImporter is the same as for EAP 6.3.0.ER7. Verified!


Note You need to log in before you can comment on or make changes to this bug.