Bug 10899 - Incorrect Kernel Version
Incorrect Kernel Version
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-18 14:49 EDT by wilfred J mrosla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 10:18:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description wilfred J mrosla 2000-04-18 14:49:22 EDT
Points to a newer version which does not exist.
Tried linking, unsuccessful
Comment 1 Bill Nottingham 2000-04-18 14:55:59 EDT
*What* points to a newer version; *where* did you try linking to?
Comment 2 Anonymous 2000-04-18 17:43:59 EDT
I forgot to mention I am using a dell inspiron 7500
As soon as I boot up:
system.map has incorrect kernel version
Activating swap partition     FAILS
/lib/modules/2.0.36/modules.dep  FAILS
filesystems mount /fs type devpts not supported by kernel

Login screen shows Kernel 2.0.36 on an i686
shows login prompt,
5 seconds later flickers then screen blanks.
Comment 3 Anonymous 2000-04-18 18:13:59 EDT
Boots clean from floppy,
noticed on login screen shows:

     Kernel 2.2.12-20

But screen still flickers and blanks.
Comment 4 Doug Ledford 2000-04-22 01:02:59 EDT
Hmmm...OK, *why* is there a 2.0.36 kernel on your laptop at all if this is a 6.1
installation?  It sounds like an upgrade where lilo and the default kernel were
not updated.  In order to fix this part of the problem, boot the laptop up using
the option single (aka, at the lilo boot: prompt, type in "linux single" without
the quotes).  This will boot you into single user mode where you can then fix
your /etc/lilo.conf file to know about and use the kernel shipped with Red Hat
6.1 (which should be /boot/vmlinuz-2.2.12-20, and since your laptop is likely an
IDE based system, there shouldn't be any need for an initrd image).
Instructions for modifying the /etc/lilo.conf are beyond these comments, but
they are available on the Red Hat support web site if you aren't familiar with
how it is done.  This will take care of the first three problems you mentioned
about modules.dep file, swap partition, and pts filesystem (or at least it
should, but possibly not the swap partition issue, you might need to verify that
the partition the system is trying to mount as a swap partition is listed as a
Linux Swap partition by fdisk -l /dev/hda).

The screen blanking issue should be solved by using the vesafb driver to init
the screen before the linux kernel takes over.  The general problem is that the
Inspiron 7500 uses an ATI video chipset and when the X server starts in order to
bring up the X server based login, it is failing to initialize the screen
properly and as a result it is going totally blank.  The resolution is to pass
the option vga=773 to the lilo boot prompt (aka, at the boot: prompt, type
"linux vga=773" without the quotes).  That will init the video subsystem and
then the X server will be able to use it properly.
Comment 5 Michael K. Johnson 2000-07-31 17:04:45 EDT
No response, does not reproduce here, can't imagine how 2.0.36 got
on an inspiron 7500 since those are very recent hardware...

Note You need to log in before you can comment on or make changes to this bug.