Bug 1090098 - FTBFS: Looks like you failed 3 tests of 15
Summary: FTBFS: Looks like you failed 3 tests of 15
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Test-LeakTrace
Version: 22
Hardware: ppc64
OS: Linux
high
high
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-22 15:01 UTC by Karsten Hopp
Modified: 2015-03-05 12:38 UTC (History)
3 users (show)

Fixed In Version: perl-Test-LeakTrace-0.15-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 12:38:01 UTC


Attachments (Terms of Use)
build.log (197.34 KB, text/plain)
2014-04-22 15:01 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2014-04-22 15:01:30 UTC
Created attachment 888522 [details]
build.log

Description of problem:
#   Failed test 'InvalidRead'
#   at /usr/share/perl5/vendor_perl/Test/Valgrind/Session.pm line 488.
#          got: 107
#     expected: 0

#   Failed test 'UninitCondition'
#   at /usr/share/perl5/vendor_perl/Test/Valgrind/Session.pm line 488.
#          got: 40
#     expected: 0

#   Failed test 'UninitValue'
#   at /usr/share/perl5/vendor_perl/Test/Valgrind/Session.pm line 488.
#          got: 3
#     expected: 0

Version-Release number of selected component (if applicable):
perl-Test-LeakTrace-0.14-8.fc21

Steps to Reproduce:
1.ppc-koji build --scratch f21 perl-Test-LeakTrace-0.14-8.fc21.sr.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1783610

Expected results:


Additional info:

Comment 1 Paul Howarth 2014-09-19 14:55:53 UTC
f21 build is now working:

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2111717

f22 build is still broken (looks like a valgrind issue):

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2111720

Comment 2 Paul Howarth 2015-02-11 16:06:45 UTC
f21 build is now failing on the spell check test:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2330427

f22 build is now passing:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2330406

I have created an update for perl-Spellunker in F21 that should fix the spell check issue:
https://admin.fedoraproject.org/updates/perl-Spellunker-0.4.0-1.fc21

Assuming that the perl-Spellunker update does indeed fix the build issue, what would be the appropriate resolution for this bug, given that I haven't actually done anything to fix the original problem? NOTABUG doesn't seem right, since there clearly was a bug.

Comment 3 Fedora Update System 2015-02-23 10:54:09 UTC
perl-Test-LeakTrace-0.15-3.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-Test-LeakTrace-0.15-3.fc21

Comment 4 Fedora Update System 2015-02-23 23:28:48 UTC
Package perl-Test-LeakTrace-0.15-3.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Test-LeakTrace-0.15-3.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2468/perl-Test-LeakTrace-0.15-3.fc21
then log in and leave karma (feedback).

Comment 5 Jaroslav Reznik 2015-03-03 17:18:31 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 6 Fedora Update System 2015-03-05 12:38:01 UTC
perl-Test-LeakTrace-0.15-3.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.