Bug 1090181 - libvirt-daemon-config-network not installed
Summary: libvirt-daemon-config-network not installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-22 20:31 UTC by Dean Hunter
Modified: 2014-05-02 20:57 UTC (History)
3 users (show)

Fixed In Version: virt-manager-1.0.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-02 20:57:34 UTC


Attachments (Terms of Use)

Description Dean Hunter 2014-04-22 20:31:25 UTC
Description of problem:

When installing virt-manager, libvirt-daemon-config-network is not installed.  When virt-manager is started, notice is given that python requires required additional software:

  qemu-system-x86
  libvirt-daemon-kvm
  libvirt-daemon-config-network

Selecting Install leads to a notice that the software is already installed.  Examination of the systems before and after shows that ony libvirt-daemon-config-network is not installed and remains uninstalled.  


Version-Release number of selected component (if applicable):

Installed Packages
virt-manager.noarch                    1.0.1-1.fc20                    installed


How reproducible: Consistent


Steps to Reproduce:
1.  Build a default Fedora 20 configuration
2.  yum install virt-manager
3.  virt-manager


Actual results:

libvirt-daemon-config-network is not installed


Expected results:

All required software installed


Additional info:

See two related bugreports: 1016606 and 1081762

Comment 1 Cole Robinson 2014-04-29 18:35:41 UTC
Hmm. Seems the InstallPackageNames API call will bail out early if any of the passed packages are already installed. So I've patched virt-manager to use the IsInstalled API to only pass that command packages that actually need installing:

commit 15449eb12601ec1b88aa6d8ee52986ef5ab41ae2
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Apr 29 14:34:31 2014 -0400

    packageutils: Fix install when one package is already installed (bz 1090181)

Comment 2 Fedora Update System 2014-04-29 18:52:42 UTC
virt-manager-1.0.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.1-3.fc20

Comment 3 Dean Hunter 2014-04-30 02:22:40 UTC
Thank you for the prompt response.  Will this patch also fix the package dependencies so that this situation need not occur?

Comment 4 Cole Robinson 2014-04-30 12:15:28 UTC
(In reply to Dean Hunter from comment #3)
> Thank you for the prompt response.  Will this patch also fix the package
> dependencies so that this situation need not occur?

No, not having a hard RPM dependency on those packages is a deliberate choice, since some users only use virt-manager to manage remote machines, so they don't want any hypervisor packages locally.

Comment 5 Dean Hunter 2014-04-30 12:49:13 UTC
It makes sense when you say it like that and that is what I am trying to do.  It would be helpful if you could find some way to make that more obvious at the time of the prompt to install missing packages.  Perhaps because virt-manager starts with a default connection to the local machine it appeared to me as if there was no choice but to install the missing packages.

Thank you, again, for your prompt response, your correction of this problem and for a fine product that I enjoy using.

Comment 6 Fedora Update System 2014-05-01 07:04:15 UTC
Package virt-manager-1.0.1-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.0.1-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5846/virt-manager-1.0.1-3.fc20
then log in and leave karma (feedback).

Comment 7 Dean Hunter 2014-05-01 15:57:37 UTC
While trying to test, what do I have to remove besides libvirt-daemon-config-network so that the test for the required packages is performed?

Comment 8 Cole Robinson 2014-05-01 16:18:51 UTC
Thanks for trying to test. You actually have to remove all connections from the main virt-manager window. So right-click->delete connection. That's kind of a pain though, so there's a hidden command line option that temporarily simulates the first run behavior. Try:

virt-manager --debug --test-first-run

Comment 9 Dean Hunter 2014-05-01 16:54:16 UTC
Thank you.  Test completed successfully and karma updated.

Comment 10 Fedora Update System 2014-05-02 20:57:34 UTC
virt-manager-1.0.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.